
Каталог CVE
CVE-2019-14863
AngularJS vulnerabilities
There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, without validating it.
- Критичність
- High · CVSS 7.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.20% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debiantrixie | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debiantrixie | angular.js | 1.8.3-3 | Fixed | [CVE-2019-14863] |
| Debiansid | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debiansid | angular.js | 1.8.3-3 | Fixed | [CVE-2019-14863] |
| Debianbookworm | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debianbookworm | angular.js | 1.8.3-1+deb12u1 | Fixed | [CVE-2019-14863] |
Showing 6 fix observations. All 17 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| UnknownRelease not reported | angular.js | 1.8.3-1ubuntu0.24.04.1 | UnknownSource applicability is not established | Provider not reported |
| UnknownRelease not reported | libjs-angularjs | 1.8.3-1ubuntu0.24.04.1 | UnknownSource applicability is not established | Provider not reported |
| Debianbookworm | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debianbookworm | angular.js | 1.8.3-1+deb12u1 | Fixed | [CVE-2019-14863] |
| Debiansid | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debiansid | angular.js | 1.8.3-3 | Fixed | [CVE-2019-14863] |
| Debiantrixie | angular.js | 1.5.3-2 | FixedDistribution-reported fixed boundary | [CVE-2019-14863] |
| Debiantrixie | angular.js | 1.8.3-3 | Fixed | [CVE-2019-14863] |
| Ubuntu22.04 | angular.js | 1.8.2-2 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntu22.04 | angular.js | 1.8.2-2ubuntu0.1 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntu24.04 | angular.js | 1.8.3-1 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntu24.04 | angular.js | 1.8.3-1ubuntu0.24.04.1 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntupro | angular.js | 1.2.28-1ubuntu2 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-14863] |
| Ubuntupro | angular.js | 1.2.28-1ubuntu2+esm1 | UnknownSource applicability is not established | [UBUNTU-CVE-2019-14863] |
| Ubuntupro | angular.js | 1.5.10-1 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntupro | angular.js | 1.7.9-1 | UnknownSource applicability is not established | [USN-7958-1] |
| Ubuntupro | angular.js | 1.7.9-1ubuntu0.1~esm1 | UnknownSource applicability is not established | [USN-7958-1] |
Original provider fields
{
"package_releases": [
{
"name": "angular.js",
"status": "fixed",
"release": "sid",
"version": "1.8.3-3"
},
{
"name": "angular.js",
"status": "fixed",
"release": "trixie",
"version": "1.8.3-3"
},
{
"name": "angular.js",
"status": "fixed",
"release": "bookworm",
"version": "1.8.3-1+deb12u1"
}
],
"fixed_versions": [
{
"bug": 942833,
"name": "angular.js",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "1.5.3-2"
},
{
"bug": 942833,
"name": "angular.js",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "1.5.3-2"
},
{
"bug": 942833,
"name": "angular.js",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "1.5.3-2"
}
],
"distribution_packages": [
{
"name": "angular.js",
"fixed_version": "1.8.3-1ubuntu0.24.04.1",
"applicability_unknown": true
},
{
"name": "libjs-angularjs",
"fixed_version": "1.8.3-1ubuntu0.24.04.1",
"applicability_unknown": true
},
{
"name": "angular.js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.9-1ubuntu0.1~esm1"
}
]
}
],
"release": "pro",
"versions": [
"1.5.10-1",
"1.7.9-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-7958-1",
"fixed_version": "1.7.9-1ubuntu0.1~esm1",
"provider_source": "pypi",
"provider_record_id": "USN-7958-1",
"provider_updated_at": "2026-06-25T13:32:31.544699605Z",
"applicability_unknown": true
},
{
"name": "angular.js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.2-2ubuntu0.1"
}
]
}
],
"release": "22.04",
"versions": [
"1.8.2-2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-7958-1",
"fixed_version": "1.8.2-2ubuntu0.1",
"provider_source": "pypi",
"provider_record_id": "USN-7958-1",
"provider_updated_at": "2026-06-25T13:32:31.544699605Z",
"applicability_unknown": true
},
{
"name": "angular.js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.3-1ubuntu0.24.04.1"
}
]
}
],
"release": "24.04",
"versions": [
"1.8.3-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-7958-1",
"fixed_version": "1.8.3-1ubuntu0.24.04.1",
"provider_source": "pypi",
"provider_record_id": "USN-7958-1",
"provider_updated_at": "2026-06-25T13:32:31.544699605Z",
"applicability_unknown": true
},
{
"name": "angular.js",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.28-1ubuntu2+esm1"
}
]
}
],
"release": "pro",
"versions": [
"1.2.28-1ubuntu2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2019-14863",
"fixed_version": "1.2.28-1ubuntu2+esm1",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2019-14863",
"provider_updated_at": "2026-02-04T02:46:03.183366Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Зіставлення пакетів триває.
[Debian 12 (Bookworm)]
- [libjs-angularjs]Невідомо
Пакет джерела: [angular.js]
Подробиці (2)
1.8.3-1+deb12u1· all · bookwormВиправлена · Виправлена:
1.5.3-2usn · angular.js · debian · bookworm; usn · angular.js · debian · 12
1.8.3-1+deb12u1· all · bookwormВиправлена · Виправлена:
1.5.3-2usn · angular.js · debian · bookworm; usn · angular.js · debian · 12
[Debian 13 (Trixie)]
- [libjs-angularjs]Невідомо
Пакет джерела: [angular.js]
Подробиці (2)
1.8.3-3· all · trixieВиправлена · Виправлена:
1.5.3-2usn · angular.js · debian · 13
1.8.3-3· all · trixieВиправлена · Виправлена:
1.5.3-2usn · angular.js · debian · 13
Спостережено:
Посилання
- [https://osv.dev/vulnerability/DEBIAN-CVE-2019-14863]
- [https://osv.dev/vulnerability/DLA-1995-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2019-14863]
- [https://osv.dev/vulnerability/USN-7958-1]
- [https://security-tracker.debian.org/tracker/CVE-2019-14863]
- [https://security.access.redhat.com/data/csaf/v2/vex/2019/cve-2019-14863.json]
- [https://ubuntu.com/security/notices/USN-7958-1]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]