
Catalogue CVE
CVE-2022-40743
trafficserver affected and fixed versions
Improper Input Validation vulnerability for the xdebug plugin in Apache Software Foundation Apache Traffic Server can lead to cross site scripting and cache poisoning attacks.This issue affects Apache Traffic Server: 9.0.0 to 9.1.3. Users should upgrade to 9.1.4 or later versions.
- Gravité
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.15% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debianbookworm-security | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2022-40743] |
| Debianbookworm | trafficserver | 9.1.4+ds-1 | FixedDistribution-reported fixed boundary | [CVE-2022-40743] |
| Debianbookworm | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2022-40743] |
Showing 3 fix observations. All 14 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debianbookworm | trafficserver | 9.1.4+ds-1 | FixedDistribution-reported fixed boundary | [CVE-2022-40743] |
| Debianbookworm | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2022-40743] |
| Debianbookworm-security | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2022-40743] |
| Ubuntu16.04 | trafficserver | 5.3.0-2ubuntu1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntu16.04 | trafficserver | 5.3.0-2ubuntu2 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntu18.04 | trafficserver | 7.0.0-5 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-3 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntupro | trafficserver | 8.1.1+ds-1.1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntupro | trafficserver | 9.1.1+ds-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1+esm1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1~esm1 | UnknownSource applicability is not established | [UBUNTU-CVE-2022-40743] |
Original provider fields
{
"package_releases": [
{
"name": "trafficserver",
"status": "fixed",
"release": "bookworm",
"version": "9.2.5+ds-0+deb12u4"
},
{
"name": "trafficserver",
"status": "fixed",
"release": "bookworm-security",
"version": "9.2.5+ds-0+deb12u4"
}
],
"fixed_versions": [
{
"bug": null,
"name": "trafficserver",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "9.1.4+ds-1"
}
],
"distribution_packages": [
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"5.3.0-2ubuntu1",
"5.3.0-2ubuntu2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-40743",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-40743",
"provider_updated_at": "2026-04-22T13:27:52.935422Z",
"applicability_unknown": true
},
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"7.0.0-5",
"7.1.2+ds-2",
"7.1.2+ds-2build1",
"7.1.2+ds-3"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-40743",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-40743",
"provider_updated_at": "2026-04-22T13:27:52.935422Z",
"applicability_unknown": true
},
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"8.1.1+ds-1.1",
"9.1.1+ds-2build1",
"9.1.1+ds-2ubuntu0.1~esm1",
"9.1.1+ds-2ubuntu0.1",
"9.1.1+ds-2ubuntu0.1+esm1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-40743",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-40743",
"provider_updated_at": "2026-04-22T13:27:52.935422Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
L’association des paquets est en cours.
[Debian 12 (Bookworm)]
- [trafficserver]Inconnu
Détails (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
- [trafficserver-dev]Inconnu
Paquet source: [trafficserver]
Détails (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
- [trafficserver-experimental-plugins]Inconnu
Paquet source: [trafficserver]
Détails (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookwormCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorrigée · Corrigée:
9.1.4+ds-1dsa · trafficserver · debian · bookworm
Observé:
Références
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-40743]
- [https://security-tracker.debian.org/tracker/CVE-2022-40743]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-40743.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2022/wid-sec-w-2022-2370.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]