
Catalogo CVE
CVE-2023-30631
trafficserver affected and fixed versions
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
- Gravità
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.00% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debianbookworm-security | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2023-30631] |
| Debianbookworm | trafficserver | 9.2.0+ds-2+deb12u1 | FixedDistribution-reported fixed boundary | [CVE-2023-30631] |
| Debianbookworm | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2023-30631] |
Showing 3 fix observations. All 14 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debianbookworm | trafficserver | 9.2.0+ds-2+deb12u1 | FixedDistribution-reported fixed boundary | [CVE-2023-30631] |
| Debianbookworm | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2023-30631] |
| Debianbookworm-security | trafficserver | 9.2.5+ds-0+deb12u4 | Fixed | [CVE-2023-30631] |
| Ubuntu16.04 | trafficserver | 5.3.0-2ubuntu1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntu16.04 | trafficserver | 5.3.0-2ubuntu2 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntu18.04 | trafficserver | 7.0.0-5 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-2 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntu18.04 | trafficserver | 7.1.2+ds-3 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntupro | trafficserver | 8.1.1+ds-1.1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntupro | trafficserver | 9.1.1+ds-2build1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1+esm1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
| Ubuntupro | trafficserver | 9.1.1+ds-2ubuntu0.1~esm1 | UnknownSource applicability is not established | [UBUNTU-CVE-2023-30631] |
Original provider fields
{
"package_releases": [
{
"name": "trafficserver",
"status": "fixed",
"release": "bookworm",
"version": "9.2.5+ds-0+deb12u4"
},
{
"name": "trafficserver",
"status": "fixed",
"release": "bookworm-security",
"version": "9.2.5+ds-0+deb12u4"
}
],
"fixed_versions": [
{
"bug": 1038248,
"name": "trafficserver",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "9.2.0+ds-2+deb12u1"
}
],
"distribution_packages": [
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "16.04",
"versions": [
"5.3.0-2ubuntu1",
"5.3.0-2ubuntu2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-30631",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-30631",
"provider_updated_at": "2026-04-22T14:06:07.825111Z",
"applicability_unknown": true
},
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"7.0.0-5",
"7.1.2+ds-2",
"7.1.2+ds-2build1",
"7.1.2+ds-3"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-30631",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-30631",
"provider_updated_at": "2026-04-22T14:06:07.825111Z",
"applicability_unknown": true
},
{
"name": "trafficserver",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "pro",
"versions": [
"8.1.1+ds-1.1",
"9.1.1+ds-2build1",
"9.1.1+ds-2ubuntu0.1~esm1",
"9.1.1+ds-2ubuntu0.1",
"9.1.1+ds-2ubuntu0.1+esm1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-30631",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-30631",
"provider_updated_at": "2026-04-22T14:06:07.825111Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
L’associazione dei pacchetti è in corso.
[Debian 12 (Bookworm)]
- [trafficserver]Sconosciuto
Dettagli (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
- [trafficserver-dev]Sconosciuto
Pacchetto sorgente: [trafficserver]
Dettagli (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
- [trafficserver-experimental-plugins]Sconosciuto
Pacchetto sorgente: [trafficserver]
Dettagli (4)
9.2.5+ds-0+deb12u4· amd64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookwormCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· amd64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
9.2.5+ds-0+deb12u4· arm64 · bookworm-securityCorretta · Corretta:
9.2.0+ds-2+deb12u1dsa · trafficserver · debian · bookworm; dsa · trafficserver · debian · 12
Osservato:
Riferimenti
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-30631]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-30631]
- [https://security-tracker.debian.org/tracker/CVE-2023-30631]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-30631.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1466.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]