
Каталог CVE
CVE-2023-31485
libgitlab-api-v4-perl affected and fixed versions
GitLab::API::v4 through 0.26 does not verify TLS certificates when connecting to a GitLab server, enabling machine-in-the-middle attacks.
- Критичність
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.65% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debiantrixie | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
| Debiansid | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
| Debianforky | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
Showing 3 fix observations. All 14 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| UnknownRelease not reported | libgitlab-api-v4-perl | Not reported | UnknownSource applicability is not established | Provider not reported |
| Debianbookworm | libgitlab-api-v4-perl | Not reported | AffectedDistribution reports no fix | [CVE-2023-31485] |
| Debianbookworm | libgitlab-api-v4-perl | 0.26-3 | Affected | [CVE-2023-31485] |
| Debianforky | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
| Debiansid | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
| Debiantrixie | libgitlab-api-v4-perl | 0.27-1 | FixedDistribution-reported fixed boundary | [CVE-2023-31485] |
| Ubuntu18.04 | libgitlab-api-v4-perl | 0.02-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu18.04 | libgitlab-api-v4-perl | 0.03-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu18.04 | libgitlab-api-v4-perl | 0.04-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu18.04 | libgitlab-api-v4-perl | 0.04-2 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu20.04 | libgitlab-api-v4-perl | 0.21-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu20.04 | libgitlab-api-v4-perl | 0.23-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu20.04 | libgitlab-api-v4-perl | 0.25-1 | Affected | [UBUNTU-CVE-2023-31485] |
| Ubuntu22.04 | libgitlab-api-v4-perl | 0.26-1 | Affected | [UBUNTU-CVE-2023-31485] |
Original provider fields
{
"package_releases": [
{
"name": "libgitlab-api-v4-perl",
"status": "fixed",
"release": "sid",
"version": "0.27-1"
},
{
"name": "libgitlab-api-v4-perl",
"status": "fixed",
"release": "forky",
"version": "0.27-1"
},
{
"name": "libgitlab-api-v4-perl",
"status": "fixed",
"release": "trixie",
"version": "0.27-1"
},
{
"name": "libgitlab-api-v4-perl",
"status": "vulnerable",
"release": "bookworm",
"version": "0.26-3"
}
],
"fixed_versions": [
{
"bug": 954051,
"name": "libgitlab-api-v4-perl",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "0.27-1"
},
{
"bug": 954051,
"name": "libgitlab-api-v4-perl",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "0.27-1"
},
{
"bug": 954051,
"name": "libgitlab-api-v4-perl",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "0.27-1"
},
{
"bug": 954051,
"name": "libgitlab-api-v4-perl",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": ""
}
],
"distribution_packages": [
{
"name": "libgitlab-api-v4-perl",
"fixed_version": "not yet fixed",
"applicability_unknown": true
},
{
"name": "libgitlab-api-v4-perl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "18.04",
"versions": [
"0.02-1",
"0.03-1",
"0.04-1",
"0.04-2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-31485",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-31485",
"provider_updated_at": "2025-10-24T05:01:58Z"
},
{
"name": "libgitlab-api-v4-perl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "20.04",
"versions": [
"0.21-1",
"0.23-1",
"0.25-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-31485",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-31485",
"provider_updated_at": "2025-10-24T05:01:58Z"
},
{
"name": "libgitlab-api-v4-perl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"release": "22.04",
"versions": [
"0.26-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-31485",
"fixed_version": "",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2023-31485",
"provider_updated_at": "2025-10-24T05:01:58Z"
}
]
}Publisher notes
[bookworm] libgitlab-api-v4-perl: Minor issue
OpenFactory catalog packages
Зіставлення пакетів триває.
[Debian 12 (Bookworm)]
- [libgitlab-api-v4-perl]Невідомо
Подробиці (2)
0.26-3· all · bookwormУражена
dsa · libgitlab-api-v4-perl · debian · bookworm; dsa · libgitlab-api-v4-perl · debian · 12
0.26-3· all · bookwormУражена
dsa · libgitlab-api-v4-perl · debian · bookworm; dsa · libgitlab-api-v4-perl · debian · 12
[Debian 13 (Trixie)]
- [libgitlab-api-v4-perl]Невідомо
Подробиці (2)
0.27-1· all · trixieВиправлена · Виправлена:
0.27-1dsa · libgitlab-api-v4-perl · debian · 13
0.27-1· all · trixieВиправлена · Виправлена:
0.27-1dsa · libgitlab-api-v4-perl · debian · 13
Спостережено: