Catálogo de CVE

CVE-2026-93592

vLLM versions before 0.28.0 fail to validate the lower…

[Catálogo de CVE]

A flaw was found in vLLM. An unauthenticated attacker can exploit an input validation vulnerability by submitting negative token IDs to the /v1/embeddings and /pooling endpoints. This action triggers a CUDA device-side assertion, which poisons the GPU context and causes the engine to crash. Consequently, all subsequent requests will fail until the process is restarted, leading to a Denial of Service (DoS). vllm: vLLM: Denial of Service via negative token ID input Red Hat has evaluated this vulnerability as having an Important severity because an unauthenticated remote attacker can completely disrupt the inference engine with a single payload. In Red Hat OpenShift AI and Red Hat AI Inference Server deployments exposing embedding or pooling models, processing negative token inputs causes an unrecoverable GPU context failure. This fault halts the entire serving process and prevents subsequent client requests from being handled until the container or process is restarted. The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.

Gravedad
High · CVSS 8.7CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.54% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
PyPIRelease not reportedvllm0.28.0UnknownSource applicability is not established[PYSEC-2026-3997]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
PyPIRelease not reportedvllm0.28.0UnknownSource applicability is not established[PYSEC-2026-3997]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "vllm",
      "ranges": [
        {
          "fixed": "0.28.0",
          "introduced": "",
          "last_affected": "",
          "start_excluding": ""
        }
      ],
      "ecosystem": "cpe",
      "provider_url": "https://nvd.nist.gov/vuln/detail/CVE-2026-93592",
      "fixed_version": "0.28.0",
      "provider_source": "nvd",
      "provider_record_id": "NVD-CVE-2026-93592",
      "provider_updated_at": "2026-09-28T18:37:06.063"
    },
    {
      "name": "vllm",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "0.28.0"
            }
          ]
        }
      ],
      "ecosystem": "PyPI",
      "provider_url": "https://osv.dev/vulnerability/PYSEC-2026-3997",
      "fixed_version": "0.28.0",
      "provider_source": "pypi",
      "provider_record_id": "PYSEC-2026-3997",
      "provider_updated_at": "2026-09-29T09:00:03.002511196Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

La asociación de paquetes está en curso.

Observado:

Referencias