Packages / openSUSE Tumbleweed / Unspecified / ghc-resolv

Package: ghc-resolv (0.2.0.3-1.8)

Lookup del Domain Name Service (DNS) tramite le routine della libreria standard libresolv

Questo pacchetto implementa un'API per accedere al servizio resolver del [Domain Name Service (DNS)](https://tools.ietf.org/html/rfc1035) tramite la libreria di sistema standard 'libresolv' (la cui API è spesso disponibile direttamente tramite la libreria C standard 'libc') sui sistemi Unix. Questo pacchetto include anche il supporto per la decodifica dei tipi di record dei messaggi definiti nei seguenti RFC: - [RFC 1035](https://tools.ietf.org/html/rfc1035): Domain Names - Implementation And Specification - [RFC 1183](https://tools.ietf.org/html/rfc1183): New DNS RR Definitions - [RFC 2782](https://tools.ietf.org/html/rfc2782): A DNS RR for specifying the location of services (DNS SRV) - [RFC 2915](https://tools.ietf.org/html/rfc2915): The Naming Authority Pointer (NAPTR) DNS Resource Record - [RFC 3596](https://tools.ietf.org/html/rfc3596): DNS Extensions to Support IP Version 6 - [RFC 4034](https://tools.ietf.org/html/rfc4034): Resource Records for the DNS Security Extensions - [RFC 4255](https://tools.ietf.org/html/rfc4255): Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints - [RFC 4408](https://tools.ietf.org/html/rfc4408): Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1 - [RFC 5155](https://tools.ietf.org/html/rfc5155): DNS Security (DNSSEC) Hashed Authenticated Denial of Existence - [RFC 6844](https://tools.ietf.org/html/rfc6844): DNS Certification Authority Authorization (CAA) Resource Record - [RFC 6891](https://tools.ietf.org/html/rfc6891): Extension Mechanisms for DNS (EDNS(0)) - [RFC 7553](https://tools.ietf.org/html/rfc7553): The Uniform Resource Identifier (URI) DNS Resource Record Per Windows, il pacchetto [windns](https://hackage.haskell.org/package/windns) fornisce un sottoinsieme compatibile dell'API di questo pacchetto.

Other Packages Related to ghc-resolv:

  • dep: libHSarray-0.5.8.0-6d05-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSbase-4.21.2.0-baed-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSbase16-bytestring-1.0.2.0-2RwapsUeTw8J8pIfvjmit3-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSbinary-0.8.9.3-52ce-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSbytestring-0.12.2.0-4850-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHScontainers-0.7-758a-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSdeepseq-1.5.1.0-4452-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-bignum-1.3-9f74-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-boot-th-9.12.4-cd4a-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-internal-9.1204.0-6f14-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-prim-0.13.0-99c1-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSpretty-1.1.3.6-9c04-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHStemplate-haskell-2.23.0.0-5865-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libgmp.so.10()(64bit)

    Package not available

  • dep: libm.so.6()(64bit)

    Package not available

  • dep: libc.so.6(GLIBC_2.34)(64bit)

    Package not available

Download ghc-resolv

ArchitecturePackage sizeInstalled sizeFilesPackage
x86_64212 KiB1.2 MiBlist of filesDownload

Percorsi file del pacchetto (5)

Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.

  • /usr/lib64/ghc-9.12.4/lib/libHSresolv-0.2.0.3-8LmKH7sAOGPIo0x4DoNmSW-ghc9.12.4.so
  • /usr/share/licenses/ghc-resolv
  • /usr/share/licenses/ghc-resolv/LICENSE
  • /usr/share/licenses/ghc-resolv/LICENSE.GPLv2
  • /usr/share/licenses/ghc-resolv/LICENSE.GPLv3

Field source: openSUSE Tumbleweed OSS

Versioni, suite e repository

Ogni riga è metadato dell'indice pacchetti per una versione, architettura, suite e repository. Nomi, URL e dimensioni arrivano dalla fonte; un link è un punto di recupero mutabile, non una redistribuzione OpenFactory.

VersionReleaseArchitectureRepositoryPackage sizeInstalled sizePublisher repository artifact
0.2.0.3-1.8tumbleweed / ossx86_64openSUSE Tumbleweed · OSS · multi-architecture212 KiB1.2 MiBx86_64/ghc-resolv-0.2.0.3-1.8.x86_64.rpm

Field source: openSUSE Tumbleweed OSS

Vulnerabilità note

Nessun avviso corrispondente nelle fonti monitorate.

Ultima sincronizzazione:

[Catalogo CVE]

Checksum

Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.

0.2.0.3-1.8 / x86_64Osservato Sep 1, 2026sha512 a793e5ce602e…0feb748aImpronta della fonte

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Impronta della fonte (sha512): a793e5ce602e66e58e7dbc03574ab6a6fd34699e661d7a6810926ac80ecdbb1aebb86a8e381b30c6d077e23285c222f4c44b1c9101facc53bd38d5380feb748a

Field source: openSUSE Tumbleweed OSS

Fonti

  • Authoritative source; repository metadata signature verified

    Prova della firma

    tumbleweed-oss-multiarch:4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f

    Repository-signature verification record
    Signed-object SHA-256
    4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f
    Signer fingerprint
    AD485664E901B867051AB15F35A2F86E29B700A4
    Keyring revision
    opensuse-project-signing-key.asc
    SHA-256 b5745739ebfb95b25b8e810f9bcb847fe750ccda598bd85f02f0e974599a6d7e
    Tool and policy
    gpgv (GnuPG) 2.4.9
    openfactory-software-catalog-signature-v1
    Verification time
    Sep 1, 2026
    Repository metadata hash linkage
    Result
    Recorded as verified; digest details unavailable