Packages / openSUSE Leap 15.6 / Unspecified / ghc-resolv

Package: ghc-resolv (0.1.2.0-bp156.5.3)

Consulta del Domain Name Service (DNS) mediante las rutinas de la biblioteca estándar libresolv

Este paquete implementa una API para acceder al servicio de resolución del [Domain Name Service (DNS)](https://tools.ietf.org/html/rfc1035) mediante la biblioteca del sistema estándar 'libresolv' (cuya API suele estar disponible directamente a través de la biblioteca C estándar 'libc') en sistemas Unix. Este paquete también incluye soporte para decodificar tipos de registros de mensajes definidos en los siguientes RFCs: - [RFC 1035](https://tools.ietf.org/html/rfc1035): Domain Names - Implementation And Specification - [RFC 1183](https://tools.ietf.org/html/rfc1183): New DNS RR Definitions - [RFC 2782](https://tools.ietf.org/html/rfc2782): A DNS RR for specifying the location of services (DNS SRV) - [RFC 2915](https://tools.ietf.org/html/rfc2915): The Naming Authority Pointer (NAPTR) DNS Resource Record - [RFC 3596](https://tools.ietf.org/html/rfc3596): DNS Extensions to Support IP Version 6 - [RFC 4034](https://tools.ietf.org/html/rfc4034): Resource Records for the DNS Security Extensions - [RFC 4255](https://tools.ietf.org/html/rfc4255): Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints - [RFC 4408](https://tools.ietf.org/html/rfc4408): Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1 - [RFC 5155](https://tools.ietf.org/html/rfc5155): DNS Security (DNSSEC) Hashed Authenticated Denial of Existence - [RFC 6844](https://tools.ietf.org/html/rfc6844): DNS Certification Authority Authorization (CAA) Resource Record - [RFC 6891](https://tools.ietf.org/html/rfc6891): Extension Mechanisms for DNS (EDNS(0)) - [RFC 7553](https://tools.ietf.org/html/rfc7553): The Uniform Resource Identifier (URI) DNS Resource Record Para Windows, el paquete [windns](https://hackage.haskell.org/package/windns) proporciona un subconjunto compatible de la API de este paquete.

Other Packages Related to ghc-resolv:

  • dep: libHSarray-0.5.4.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbase-4.14.3.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbase16-bytestring-1.0.2.0-IuhVh6qIVHnAAwYIXQtuOv-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbinary-0.8.8.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbytestring-0.10.12.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHScontainers-0.6.5.1-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSdeepseq-1.4.4.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSghc-prim-0.6.1-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSinteger-gmp-1.0.3.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libgmp.so.10()(64bit)

    Package not available

  • dep: libm.so.6()(64bit)

    Package not available

  • dep: libc.so.6(GLIBC_2.34)(64bit)

    Package not available

Download ghc-resolv

ArchitecturePackage sizeInstalled sizeFilesPackage
aarch64225 KiB1.5 MiBlist of filesDownload
ppc64le244 KiB2.0 MiBlist of filesDownload
s390x360 KiB2.7 MiBlist of filesDownload
x86_64197 KiB1.2 MiBlist of filesDownload

Rutas de archivos del paquete (6)

Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.

  • /usr/lib64/ghc-8.10.7/resolv-0.1.2.0
  • /usr/lib64/ghc-8.10.7/resolv-0.1.2.0/libHSresolv-0.1.2.0-EKMffnjRthx4kRw5vMMHrj-ghc8.10.7.so
  • /usr/share/licenses/ghc-resolv
  • /usr/share/licenses/ghc-resolv/LICENSE
  • /usr/share/licenses/ghc-resolv/LICENSE.GPLv2
  • /usr/share/licenses/ghc-resolv/LICENSE.GPLv3

Field source: openSUSE Leap 15.6 OSS

Versiones, suites y repositorios

Cada fila es metadato del índice de paquetes para una versión, arquitectura, suite y repositorio. Nombres, URL y tamaños vienen de la fuente; un enlace es un punto de descarga que puede cambiar, no una redistribución de OpenFactory.

VersionReleaseArchitectureRepositoryPackage sizeInstalled sizePublisher repository artifact
0.1.2.0-bp156.5.3leap-15.6 / ossaarch64openSUSE Leap 15.6 · OSS · multi-architecture225 KiB1.5 MiBaarch64/ghc-resolv-0.1.2.0-bp156.5.3.aarch64.rpm
0.1.2.0-bp156.5.3leap-15.6 / ossppc64leopenSUSE Leap 15.6 · OSS · multi-architecture244 KiB2.0 MiBppc64le/ghc-resolv-0.1.2.0-bp156.5.3.ppc64le.rpm
0.1.2.0-bp156.5.3leap-15.6 / osss390xopenSUSE Leap 15.6 · OSS · multi-architecture360 KiB2.7 MiBs390x/ghc-resolv-0.1.2.0-bp156.5.3.s390x.rpm
0.1.2.0-bp156.5.3leap-15.6 / ossx86_64openSUSE Leap 15.6 · OSS · multi-architecture197 KiB1.2 MiBx86_64/ghc-resolv-0.1.2.0-bp156.5.3.x86_64.rpm

Field source: openSUSE Leap 15.6 OSS

Vulnerabilidades conocidas

No hay avisos coincidentes en las fuentes consultadas.

Última sincronización:

[Catálogo de CVE]

Sumas de comprobación

Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.

0.1.2.0-bp156.5.3 / aarch64Observado Sep 1, 2026sha512 77a8a5820ae2…62ffb643Resumen de la fuente

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Resumen de la fuente (sha512): 77a8a5820ae21c7ce7aeac715d4cb512d4f518ac52cd1d4497414fc106914fa7c1ab312d5ee123b2a941f9d60695fe1af9cf18ab703a79c0559d722362ffb643

Field source: openSUSE Leap 15.6 OSS

0.1.2.0-bp156.5.3 / ppc64leObservado Sep 1, 2026sha512 826007ec0f2b…226078b0Resumen de la fuente

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Resumen de la fuente (sha512): 826007ec0f2b13f6480a57cab91100f35f3854031ada264d62ee9fc24927fc0ac57eadb4ca4933c8f74e69040ba7c20cff5d84225522f89385492a8e226078b0

Field source: openSUSE Leap 15.6 OSS

0.1.2.0-bp156.5.3 / s390xObservado Sep 1, 2026sha512 15a31a328227…afca4c77Resumen de la fuente

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Resumen de la fuente (sha512): 15a31a32822770fdede125dce0acbb47c91266c6bc711e97e22ae23eae8f9ee07c981fcee4d17d24827a102fc2529d201f3b5ad2a726ff0b1fe287baafca4c77

Field source: openSUSE Leap 15.6 OSS

0.1.2.0-bp156.5.3 / x86_64Observado Sep 1, 2026sha512 20c66d48ac4f…986bb554Resumen de la fuente

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Resumen de la fuente (sha512): 20c66d48ac4f691abe9954e3f67f410801d86c5ec943afe25e07a491f4acc3b30b6f03e62387f7c945c5846d04c0f3134d0d020fcaf80cbb105d183a986bb554

Field source: openSUSE Leap 15.6 OSS

Fuentes

  • Authoritative source; repository metadata signature verified

    Prueba de firma

    leap-15-6-oss-multiarch:ca2653101b9afba6656aea529109ba0c0f1ca1a92aa8614e7c887fda5264c230

    Repository-signature verification record
    Signed-object SHA-256
    ca2653101b9afba6656aea529109ba0c0f1ca1a92aa8614e7c887fda5264c230
    Signer fingerprint
    AD485664E901B867051AB15F35A2F86E29B700A4
    Keyring revision
    opensuse-project-signing-key.asc
    SHA-256 b5745739ebfb95b25b8e810f9bcb847fe750ccda598bd85f02f0e974599a6d7e
    Tool and policy
    gpgv (GnuPG) 2.4.9
    openfactory-software-catalog-signature-v1
    Verification time
    Sep 1, 2026
    Repository metadata hash linkage
    Result
    Recorded as verified; digest details unavailable