Consulta del Domain Name Service (DNS) mediante las rutinas de la biblioteca estándar libresolv
Este paquete implementa una API para acceder al servicio de resolución del [Domain Name Service
(DNS)](https://tools.ietf.org/html/rfc1035) mediante la biblioteca
del sistema estándar 'libresolv' (cuya API suele estar disponible directamente a través de la
biblioteca C estándar 'libc') en sistemas Unix.
Este paquete también incluye soporte para decodificar tipos de registros de mensajes definidos
en los siguientes RFCs:
- [RFC 1035](https://tools.ietf.org/html/rfc1035): Domain Names -
Implementation And Specification - [RFC
1183](https://tools.ietf.org/html/rfc1183): New DNS RR Definitions - [RFC
2782](https://tools.ietf.org/html/rfc2782): A DNS RR for specifying the
location of services (DNS SRV) - [RFC
2915](https://tools.ietf.org/html/rfc2915): The Naming Authority Pointer
(NAPTR) DNS Resource Record - [RFC 3596](https://tools.ietf.org/html/rfc3596):
DNS Extensions to Support IP Version 6 - [RFC
4034](https://tools.ietf.org/html/rfc4034): Resource Records for the DNS
Security Extensions - [RFC 4255](https://tools.ietf.org/html/rfc4255): Using
DNS to Securely Publish Secure Shell (SSH) Key Fingerprints - [RFC
4408](https://tools.ietf.org/html/rfc4408): Sender Policy Framework (SPF) for
Authorizing Use of Domains in E-Mail, Version 1 - [RFC
5155](https://tools.ietf.org/html/rfc5155): DNS Security (DNSSEC) Hashed
Authenticated Denial of Existence - [RFC
6844](https://tools.ietf.org/html/rfc6844): DNS Certification Authority
Authorization (CAA) Resource Record - [RFC
6891](https://tools.ietf.org/html/rfc6891): Extension Mechanisms for DNS
(EDNS(0)) - [RFC 7553](https://tools.ietf.org/html/rfc7553): The Uniform
Resource Identifier (URI) DNS Resource Record
Para Windows, el paquete [windns](https://hackage.haskell.org/package/windns)
proporciona un subconjunto compatible de la API de este paquete.
Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.
Cada fila es metadato del índice de paquetes para una versión, arquitectura, suite y repositorio. Nombres, URL y tamaños vienen de la fuente; un enlace es un punto de descarga que puede cambiar, no una redistribución de OpenFactory.
Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.
0.2.0.2-bp160.1.13 / aarch64Observado Sep 1, 2026sha512 19a93ae79aa6…d9c59acaResumen de la fuente
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Resumen de la fuente (sha512): 19a93ae79aa622b9491b0f52f684f97b34b803227b5b8f6756e2937118c08d078eede2f787060177681d26f3e2417a13e8d071a48a568484308b9126d9c59aca
0.2.0.2-bp160.1.13 / ppc64leObservado Sep 1, 2026sha512 b5a6542b613b…2ebde9fbResumen de la fuente
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Resumen de la fuente (sha512): b5a6542b613b9a51cdcaa3daa5108dadcf484f798d779148b54fe485e440d0124487f569c07718f24e0a2bf834448c4a4617e82935701245417563822ebde9fb
0.2.0.2-bp160.1.13 / x86_64Observado Sep 1, 2026sha512 400a55227a51…f92b68d5Resumen de la fuente
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Resumen de la fuente (sha512): 400a55227a51ed642605566dba6587454bde0090b4258edf6c481679f97e508bce680543a91410863cc4a6c4020a14d1fb1f6e64d3fe69621d4f14b0f92b68d5