Packages / openSUSE Leap 15.6 / Unspecified / ghc-cryptohash-sha256

Package: ghc-cryptohash-sha256 (0.11.102.1-bp156.3.3)

Implementazione SHA-256 veloce, pura e pratica

Un'API pratica, incrementale e a passaggio unico, pura, per l'[algoritmo di hash crittografico SHA-256](https://en.wikipedia.org/wiki/SHA-2) secondo [FIPS 180-4](http://dx.doi.org/10.6028/NIST.FIPS.180-4) con prestazioni vicine alle implementazioni più veloci disponibili in altri linguaggi. L'algoritmo SHA-256 di base è implementato in C e si prevede quindi che sia altrettanto veloce dello strumento standard [sha256sum(1)](https://linux.die.net/man/1/sha256sum); ad esempio, su un /Intel Core i7-3770/ a 3.40GHz questa implementazione può calcolare un hash SHA-256 su 230 MiB di dati in meno di un secondo. (Se invece serve un'implementazione Haskell pura e le prestazioni sono secondarie, si veda il [pacchetto SHA](https://hackage.haskell.org/package/SHA).) Inoltre, questo pacchetto fornisce supporto per - HMAC-SHA-256: [Hashed Message Authentication Codes](https://en.wikipedia.org/wiki/HMAC) (HMAC) basati su SHA-256 - HKDF-SHA-256: [HMAC-SHA-256-based Key Derivation Function](https://en.wikipedia.org/wiki/HKDF) (HKDF) in conformità a [RFC6234](https://tools.ietf.org/html/rfc6234), [RFC4231](https://tools.ietf.org/html/rfc4231), [RFC5869](https://tools.ietf.org/html/rfc5869), ecc. === Relazione con il pacchetto 'cryptohash' e la sua API Questo pacchetto era originariamente un fork di 'cryptohash-0.11.7' perché il pacchetto 'cryptohash' era stato deprecato; così questo pacchetto continua a soddisfare l'esigenza di un pacchetto leggero che fornisca l'algoritmo di hash SHA-256 senza dipendenze da pacchetti diversi da 'base' e 'bytestring'. L'API esposta da 'cryptohash-sha256-0.11.*' tramite il modulo "Crypto.Hash.SHA256" è garantita come un sovrainsieme compatibile dell'API fornita dal modulo omonimo di 'cryptohash-0.11.7'. Di conseguenza, questo pacchetto è progettato per essere usato come sostituto drop-in del modulo "Crypto.Hash.SHA256" di 'cryptohash-0.11.7', sebbene con un [impronta chiaramente più piccola di quasi 3 ordini di grandezza](https://www.reddit.com/r/haskell/comments/5lxv75/psa_please_use_unique_module_names_when_uploading/dbzegx3/).

Other Packages Related to ghc-cryptohash-sha256:

  • dep: libHSarray-0.5.4.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbase-4.14.3.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSbytestring-0.10.12.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSdeepseq-1.4.4.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSghc-prim-0.6.1-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libHSinteger-gmp-1.0.3.0-ghc8.10.7.so()(64bit)

    Package not available

  • dep: libgmp.so.10()(64bit)

    Package not available

  • dep: libm.so.6()(64bit)

    Package not available

  • dep: libc.so.6(GLIBC_2.17)(64bit)

    Package not available

Download ghc-cryptohash-sha256

ArchitecturePackage sizeInstalled sizeFilesPackage
aarch6427 KiB70 KiBlist of filesDownload
ppc64le28 KiB134 KiBlist of filesDownload
s390x34 KiB106 KiBlist of filesDownload
x86_6428 KiB62 KiBlist of filesDownload

Percorsi file del pacchetto (4)

Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.

  • /usr/lib64/ghc-8.10.7/cryptohash-sha256-0.11.102.1
  • /usr/lib64/ghc-8.10.7/cryptohash-sha256-0.11.102.1/libHScryptohash-sha256-0.11.102.1-Bq7Bjd1hFAtEvcz1tdRIfz-ghc8.10.7.so
  • /usr/share/licenses/ghc-cryptohash-sha256
  • /usr/share/licenses/ghc-cryptohash-sha256/LICENSE

Field source: openSUSE Leap 15.6 OSS

Usa questo pacchetto

OpenFactory può avviare questo sistema operativo in una macchina virtuale del browser, o iniziare una costruzione che include il nome nativo del pacchetto di questo record.

Versioni, suite e repository

Ogni riga è metadato dell'indice pacchetti per una versione, architettura, suite e repository. Nomi, URL e dimensioni arrivano dalla fonte; un link è un punto di recupero mutabile, non una redistribuzione OpenFactory.

VersionReleaseArchitectureRepositoryPackage sizeInstalled sizePublisher repository artifact
0.11.102.1-bp156.3.3leap-15.6 / ossaarch64openSUSE Leap 15.6 · OSS · multi-architecture27 KiB70 KiBaarch64/ghc-cryptohash-sha256-0.11.102.1-bp156.3.3.aarch64.rpm
0.11.102.1-bp156.3.3leap-15.6 / ossppc64leopenSUSE Leap 15.6 · OSS · multi-architecture28 KiB134 KiBppc64le/ghc-cryptohash-sha256-0.11.102.1-bp156.3.3.ppc64le.rpm
0.11.102.1-bp156.3.3leap-15.6 / osss390xopenSUSE Leap 15.6 · OSS · multi-architecture34 KiB106 KiBs390x/ghc-cryptohash-sha256-0.11.102.1-bp156.3.3.s390x.rpm
0.11.102.1-bp156.3.3leap-15.6 / ossx86_64openSUSE Leap 15.6 · OSS · multi-architecture28 KiB62 KiBx86_64/ghc-cryptohash-sha256-0.11.102.1-bp156.3.3.x86_64.rpm

Field source: openSUSE Leap 15.6 OSS

Vulnerabilità note

Nessun avviso corrispondente nelle fonti monitorate.

Ultima sincronizzazione:

[Catalogo CVE]

Checksum

Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.

0.11.102.1-bp156.3.3 / aarch64Osservato Sep 1, 2026sha512 76cd5f6f06b2…3809ce45Impronta della fonte

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Impronta della fonte (sha512): 76cd5f6f06b296f71a7b8df83530095b8ac98737218e481702ef6962993fd9d8b979494e4d5986bcd6161cf70236b94cfdfd84db1c31e4ad29f99af13809ce45

Field source: openSUSE Leap 15.6 OSS

0.11.102.1-bp156.3.3 / ppc64leOsservato Sep 1, 2026sha512 b3a495c879c9…09687771Impronta della fonte

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Impronta della fonte (sha512): b3a495c879c94211a3a440c0c340be529e08f879d996b87c3f8e6d0af4785f2f828b40aca5111e3646331e9b41c61a1b622c3411c781560c8521760809687771

Field source: openSUSE Leap 15.6 OSS

0.11.102.1-bp156.3.3 / s390xOsservato Sep 1, 2026sha512 dd50b076885d…dff38558Impronta della fonte

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Impronta della fonte (sha512): dd50b076885d35f6ab023b1e19c6444de87ca445970bb0cb77c1ceb5a9f14c6e06fb0d66c7df4af34b4294ae0b5ef7b31f29afc4e5d8770230566dcedff38558

Field source: openSUSE Leap 15.6 OSS

0.11.102.1-bp156.3.3 / x86_64Osservato Sep 1, 2026sha512 48cc35e81450…44ec1d62Impronta della fonte

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Impronta della fonte (sha512): 48cc35e814505e2a647ddc2eeee3c2aa3129c80c9c9384db8f71de47b8efb54fc07e82085f3e3f93a689ca91b532b852be863629a78c1a7f43df93a544ec1d62

Field source: openSUSE Leap 15.6 OSS

Fonti

  • Authoritative source; repository metadata signature verified

    Prova della firma

    leap-15-6-oss-multiarch:ca2653101b9afba6656aea529109ba0c0f1ca1a92aa8614e7c887fda5264c230

    Repository-signature verification record
    Signed-object SHA-256
    ca2653101b9afba6656aea529109ba0c0f1ca1a92aa8614e7c887fda5264c230
    Signer fingerprint
    AD485664E901B867051AB15F35A2F86E29B700A4
    Keyring revision
    opensuse-project-signing-key.asc
    SHA-256 b5745739ebfb95b25b8e810f9bcb847fe750ccda598bd85f02f0e974599a6d7e
    Tool and policy
    gpgv (GnuPG) 2.4.9
    openfactory-software-catalog-signature-v1
    Verification time
    Sep 1, 2026
    Repository metadata hash linkage
    Result
    Recorded as verified; digest details unavailable