Schnelle, reine und praxisnahe SHA-256-Implementierung
Eine praxisnahe inkrementelle und Einpass-API in reinem Stil für den [kryptografischen Hash-Algorithmus SHA-256](https://en.wikipedia.org/wiki/SHA-2) gemäß [FIPS
180-4](http://dx.doi.org/10.6028/NIST.FIPS.180-4) mit einer Leistung nahe den
schnellsten Implementierungen in anderen Sprachen.
Der Kernalgorithmus SHA-256 ist in C implementiert und sollte daher ebenso
schnell sein wie das Standardwerkzeug [sha256sum(1)](https://linux.die.net/man/1/sha256sum); beispielsweise kann diese Implementierung auf einem /Intel Core
i7-3770/ mit 3,40 GHz einen SHA-256-Hash über 230 MiB
Daten in unter einer Sekunde berechnen. (Wenn Sie stattdessen eine reine Haskell-
Implementierung benötigen und Leistung zweitrangig ist, siehe das [SHA-
Paket](https://hackage.haskell.org/package/SHA).)
Zusätzlich bietet dieses Paket Unterstützung für
- HMAC-SHA-256: SHA-256-basierte [Hashed Message Authentication
Codes](https://en.wikipedia.org/wiki/HMAC) (HMAC) - HKDF-SHA-256:
[HMAC-SHA-256-basierte Key Derivation
Function](https://en.wikipedia.org/wiki/HKDF) (HKDF)
konform zu [RFC6234](https://tools.ietf.org/html/rfc6234),
[RFC4231](https://tools.ietf.org/html/rfc4231),
[RFC5869](https://tools.ietf.org/html/rfc5869) u. a.
=== Beziehung zum Paket 'cryptohash' und seiner API
Dieses Paket war ursprünglich ein Fork von 'cryptohash-0.11.7', weil das
Paket 'cryptohash' veraltet war; dieses Paket deckt weiterhin den Bedarf an einem
schlanken Paket für den SHA-256-Hash-Algorithmus ohne Abhängigkeiten von anderen
Paketen außer 'base' und 'bytestring'.
Die von 'cryptohash-sha256-0.11.*' über das Modul "Crypto.Hash.SHA256" bereitgestellte API bleibt
garantiert eine kompatible Obermenge der API des gleichnamigen Moduls von
'cryptohash-0.11.7'.
Entsprechend ist dieses Paket als Drop-in-Ersatz für das Modul
"Crypto.Hash.SHA256" von 'cryptohash-0.11.7' gedacht, jedoch mit einem [deutlich
kleineren Footprint um nahezu drei Größenordnungen](https://www.reddit.com/r/haskell/comments/5lxv75/psa_please_use_unique_module_names_when_uploading/dbzegx3/).
Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.
Jede Zeile ist Paketindex-Metadaten für eine Version, Architektur, Suite und ein Repository. Namen, URLs und Größen stammen aus der Quelle; ein Link ist ein veränderbarer Abrufort, kein Weitergabanspruch von OpenFactory.
Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.
0.11.102.1-bp160.1.13 / aarch64Beobachtet Sep 1, 2026sha512 f59c693e8320…312c615ePrüfsumme der Quelle
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Prüfsumme der Quelle (sha512): f59c693e8320f4d1d9e1b4c20f2e81d50c1bacaf225f8b563df46054f0c9f2c6bafd5e29d3140df8e01153a9090a07e497595a9dcc0ddc1245894b12312c615e
0.11.102.1-bp160.1.13 / ppc64leBeobachtet Sep 1, 2026sha512 30107ee837d5…ba984e74Prüfsumme der Quelle
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Prüfsumme der Quelle (sha512): 30107ee837d5d3ae0d0977265bf7afc52af4ce48fa4c1b5979458b0b976a7143891eae7e353624a8c26be51fcbe8acdb22ea1f28871e171f2ab9b8c9ba984e74
0.11.102.1-bp160.1.13 / x86_64Beobachtet Sep 1, 2026sha512 d2a0a4d5eaf5…2d633a75Prüfsumme der Quelle
Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.
Prüfsumme der Quelle (sha512): d2a0a4d5eaf5f4bf4de388868d0aa3416954178a8cbe6aef57d66bb1a9e5722870bd5589d6950b6c8b0005793902db5ecf710a2838fbab121355e0fd2d633a75