Packages / openSUSE Tumbleweed / Unspecified / ghc-cryptohash-sha256

Package: ghc-cryptohash-sha256 (0.11.102.1-7.12)

Implémentation SHA-256 rapide, pure et pratique

Une API pratique incrémentale et en une passe, pure, pour l'[algorithme de hachage cryptographique SHA-256](https://en.wikipedia.org/wiki/SHA-2) selon [FIPS 180-4](http://dx.doi.org/10.6028/NIST.FIPS.180-4) avec des performances proches des implementations les plus rapides disponibles dans d'autres langages. L'algorithme SHA-256 de base est implémenté en C et devrait donc être aussi rapide que l'outil standard [sha256sum(1) ](https://linux.die.net/man/1/sha256sum) ; par exemple, sur un /Intel Core i7-3770/ à 3,40 GHz, cette implémentation peut calculer un hachage SHA-256 sur 230 MiB de données en moins d'une seconde. (Si, au contraire, vous avez besoin d'une implémentation pure en Haskell et que les performances sont secondaires, veuillez vous référer au [paquet SHA](https://hackage.haskell.org/package/SHA).) De plus, ce paquet fournit la prise en charge de - HMAC-SHA-256 : [Hashed Message Authentication Codes](https://en.wikipedia.org/wiki/HMAC) (HMAC) basés sur SHA-256 - HKDF-SHA-256 : [HMAC-SHA-256-based Key Derivation Function](https://en.wikipedia.org/wiki/HKDF) (HKDF) conformément à [RFC6234](https://tools.ietf.org/html/rfc6234), [RFC4231](https://tools.ietf.org/html/rfc4231), [RFC5869](https://tools.ietf.org/html/rfc5869), etc. === Relation avec le paquet 'cryptohash' et son API Ce paquet était à l'origine un fork de 'cryptohash-0.11.7' car le paquet 'cryptohash' avait été déprécié ; ce paquet continue donc de répondre au besoin d'un paquet léger fournissant l'algorithme de hachage SHA-256 sans dépendances autres que 'base' et 'bytestring'. L'API exposée par le module "Crypto.Hash.SHA256" de 'cryptohash-sha256-0.11.*' est garantie comme un sur-ensemble compatible de l'API fournie par le module du même nom dans 'cryptohash-0.11.7'. Par conséquent, ce paquet est conçu pour être utilisé comme remplacement immédiat du module "Crypto.Hash.SHA256" de 'cryptohash-0.11.7', mais avec une [empreinte clairement plus petite de près de 3 ordres de grandeur](https://www.reddit.com/r/haskell/comments/5lxv75/psa_please_use_unique_module_names_when_uploading/dbzegx3/).

Other Packages Related to ghc-cryptohash-sha256:

  • dep: libHSbase-4.21.2.0-baed-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSbytestring-0.12.2.0-4850-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSdeepseq-1.5.1.0-4452-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-bignum-1.3-9f74-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-boot-th-9.12.4-cd4a-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-internal-9.1204.0-6f14-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSghc-prim-0.13.0-99c1-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHSpretty-1.1.3.6-9c04-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libHStemplate-haskell-2.23.0.0-5865-ghc9.12.4.so()(64bit)

    Package not available

  • dep: libgmp.so.10()(64bit)

    Package not available

  • dep: libm.so.6()(64bit)

    Package not available

  • dep: libc.so.6(GLIBC_2.14)(64bit)

    Package not available

Download ghc-cryptohash-sha256

ArchitecturePackage sizeInstalled sizeFilesPackage
x86_6429 KiB78 KiBlist of filesDownload

Chemins de fichiers du paquet (3)

Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.

  • /usr/lib64/ghc-9.12.4/lib/libHScryptohash-sha256-0.11.102.1-1He9hXiEXN98YmpngCyoR8-ghc9.12.4.so
  • /usr/share/licenses/ghc-cryptohash-sha256
  • /usr/share/licenses/ghc-cryptohash-sha256/LICENSE

Field source: openSUSE Tumbleweed OSS

Utiliser ce paquet

OpenFactory peut démarrer ce système d'exploitation dans une machine virtuelle du navigateur, ou lancer une construction qui inclut le nom natif du paquet de cet enregistrement.

Versions, suites et dépôts

Chaque ligne est une métadonnée d'index pour une version, une architecture, une suite et un dépôt. Noms, URL et tailles viennent de la source ; un lien est un emplacement de récupération mutable, pas une redistribution OpenFactory.

VersionReleaseArchitectureRepositoryPackage sizeInstalled sizePublisher repository artifact
0.11.102.1-7.12tumbleweed / ossx86_64openSUSE Tumbleweed · OSS · multi-architecture29 KiB78 KiBx86_64/ghc-cryptohash-sha256-0.11.102.1-7.12.x86_64.rpm

Field source: openSUSE Tumbleweed OSS

Vulnérabilités connues

Aucun avis correspondant dans les sources suivies.

Dernière synchronisation:

[Catalogue CVE]

Empreintes

Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.

0.11.102.1-7.12 / x86_64Observé Sep 1, 2026sha512 ee778e0871c3…ca7330abEmpreinte publiée par la source

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Empreinte publiée par la source (sha512): ee778e0871c34b2e18cc6105674a7ac77495dbf1ad4762e309d48469ddbf5163b0af3546fd07ec357ed80b810cb9aa15955f1d45caa43b345982071aca7330ab

Field source: openSUSE Tumbleweed OSS

Sources

  • Authoritative source; repository metadata signature verified

    Preuve de signature

    tumbleweed-oss-multiarch:4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f

    Repository-signature verification record
    Signed-object SHA-256
    4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f
    Signer fingerprint
    AD485664E901B867051AB15F35A2F86E29B700A4
    Keyring revision
    opensuse-project-signing-key.asc
    SHA-256 b5745739ebfb95b25b8e810f9bcb847fe750ccda598bd85f02f0e974599a6d7e
    Tool and policy
    gpgv (GnuPG) 2.4.9
    openfactory-software-catalog-signature-v1
    Verification time
    Sep 1, 2026
    Repository metadata hash linkage
    Result
    Recorded as verified; digest details unavailable