CVE catalog

CVE-2001-1413

ncompress: CVE-2001-1413

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.78% · Oct 25, 2026

Stack-based buffer overflow in the comprexx function for ncompress 4.2.4 and earlier, when used in situations that cross security boundaries (such as FTP server), may allow remote attackers to execute arbitrary code via a long filename argument.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianncompresssid5.0-5fixed
Debianncompressforky5.0-5fixed
Debianncompresstrixie5.0-3fixed
Debianncompressbookworm4.2.4.6-6fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianncompresssourcesid4.2.4-15not yet assignedNot reportedNot reported
Debianncompresssourceforky4.2.4-15not yet assignedNot reportedNot reported
Debianncompresssourcetrixie4.2.4-15not yet assignedNot reportedNot reported
Debianncompresssourcebookworm4.2.4-15not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ncompress]Fixed
    Details (2)
    • 4.2.4.6-6 · amd64 · bookworm

      Fixed · Fixed: 4.2.4-15

      dsa · ncompress · debian · bookworm; dsa · ncompress · debian · 12

    • 4.2.4.6-6 · arm64 · bookworm

      Fixed · Fixed: 4.2.4-15

      dsa · ncompress · debian · bookworm; dsa · ncompress · debian · 12

[Debian 13 (Trixie)]

  • [ncompress]Fixed
    Details (2)
    • 5.0-3 · amd64 · trixie

      Fixed · Fixed: 4.2.4-15

      dsa · ncompress · debian · 13

    • 5.0-3 · arm64 · trixie

      Fixed · Fixed: 4.2.4-15

      dsa · ncompress · debian · 13

Observed:

References