CVE catalog

CVE-2002-2207

ssldump: CVE-2002-2207

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
5.44% · Oct 25, 2026

Buffer overflow in ssldump 0.9b2 and earlier, when running in decryption mode, allows remote attackers to execute arbitrary code via a long RSA PreMasterSecret.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianssldumpsid1.9-2fixed
Debianssldumpforky1.9-2fixed
Debianssldumptrixie1.9-1fixed
Debianssldumpbookworm1.5-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianssldumpsourcesid0.9b3not yet assignedNot reportedNot reported
Debianssldumpsourceforky0.9b3not yet assignedNot reportedNot reported
Debianssldumpsourcetrixie0.9b3not yet assignedNot reportedNot reported
Debianssldumpsourcebookworm0.9b3not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ssldump]Fixed
    Details (2)
    • 1.5-1 · amd64 · bookworm

      Fixed · Fixed: 0.9b3

      dsa · ssldump · debian · bookworm; dsa · ssldump · debian · 12

    • 1.5-1 · arm64 · bookworm

      Fixed · Fixed: 0.9b3

      dsa · ssldump · debian · bookworm; dsa · ssldump · debian · 12

[Debian 13 (Trixie)]

  • [ssldump]Fixed
    Details (2)
    • 1.9-1 · amd64 · trixie

      Fixed · Fixed: 0.9b3

      dsa · ssldump · debian · 13

    • 1.9-1 · arm64 · trixie

      Fixed · Fixed: 0.9b3

      dsa · ssldump · debian · 13

Observed:

References