CVE catalog

CVE-2003-0630

atari800: CVE-2003-0630

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.37% · Oct 25, 2026

Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianatari800sid7.2.1-1fixed
Debianatari800forky7.2.1-1fixed
Debianatari800trixie5.2.0-2fixed
Debianatari800bookworm5.0.0-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianatari800sourcesid1.3.1-2not yet assignedNot reportedNot reported
Debianatari800sourceforky1.3.1-2not yet assignedNot reportedNot reported
Debianatari800sourcetrixie1.3.1-2not yet assignedNot reportedNot reported
Debianatari800sourcebookworm1.3.1-2not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [atari800]Fixed
    Details (2)
    • 5.0.0-1 · amd64 · bookworm

      Fixed · Fixed: 1.3.1-2

      dsa · atari800 · debian · bookworm; dsa · atari800 · debian · 12

    • 5.0.0-1 · arm64 · bookworm

      Fixed · Fixed: 1.3.1-2

      dsa · atari800 · debian · bookworm; dsa · atari800 · debian · 12

[Debian 13 (Trixie)]

  • [atari800]Fixed
    Details (2)
    • 5.2.0-2 · amd64 · trixie

      Fixed · Fixed: 1.3.1-2

      dsa · atari800 · debian · 13

    • 5.2.0-2 · arm64 · trixie

      Fixed · Fixed: 1.3.1-2

      dsa · atari800 · debian · 13

Observed:

References