CVE catalog

CVE-2004-0993

hpsockd: CVE-2004-0993

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
10.17% · Oct 27, 2026

Buffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianhpsockdsid0.17+x-1fixed
Debianhpsockdforky0.17+x-1fixed
Debianhpsockdtrixie0.17+x-0.1fixed
Debianhpsockdbookworm0.17+nmu1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianhpsockdsourcesid0.14not yet assignedNot reportedNot reported
Debianhpsockdsourceforky0.14not yet assignedNot reportedNot reported
Debianhpsockdsourcetrixie0.14not yet assignedNot reportedNot reported
Debianhpsockdsourcebookworm0.14not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [hpsockd]Fixed
    Details (2)
    • 0.17+nmu1 · amd64 · bookworm

      Fixed · Fixed: 0.14

      dsa · hpsockd · debian · bookworm; dsa · hpsockd · debian · 12

    • 0.17+nmu1 · arm64 · bookworm

      Fixed · Fixed: 0.14

      dsa · hpsockd · debian · bookworm; dsa · hpsockd · debian · 12

[Debian 13 (Trixie)]

  • [hpsockd]Fixed
    Details (2)
    • 0.17+x-0.1 · amd64 · trixie

      Fixed · Fixed: 0.14

      dsa · hpsockd · debian · 13

    • 0.17+x-0.1 · arm64 · trixie

      Fixed · Fixed: 0.14

      dsa · hpsockd · debian · 13

Observed:

References