CVE catalog

CVE-2004-2664

libphp-adodb: CVE-2004-2664

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
1.20% · Oct 25, 2026

John Lim ADOdb Library for PHP before 4.23 allows remote attackers to obtain sensitive information via direct requests to certain scripts that result in an undefined value of ADODB_DIR, which reveals the installation path in an error message.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibphp-adodbsid5.22.12-1not affected
Debianlibphp-adodbforky5.22.12-1not affected
Debianlibphp-adodbtrixie5.22.9-0.1+deb13u1not affected
Debianlibphp-adodbbookworm5.21.4-1+deb12u2not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibphp-adodbsourcesidNot affectedunimportantNot reportedNot reported
Debianlibphp-adodbsourceforkyNot affectedunimportantNot reportedNot reported
Debianlibphp-adodbsourcetrixieNot affectedunimportantNot reportedNot reported
Debianlibphp-adodbsourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [libphp-adodb]Not affected
    Details (4)
    • 5.21.4-1+deb12u2 · all · bookworm

      Not affected

      dsa · libphp-adodb · debian · bookworm

    • 5.21.4-1+deb12u2 · all · bookworm

      Not affected

      dsa · libphp-adodb · debian · bookworm

    • 5.22.9-0.1~bpo12+1 · all · bookworm-backports

      Not affected

      dsa · libphp-adodb · debian · bookworm

    • 5.22.9-0.1~bpo12+1 · all · bookworm-backports

      Not affected

      dsa · libphp-adodb · debian · bookworm

[Debian 13 (Trixie)]

  • [phppgadmin]Fixed
    Details (2)
    • 7.14.7+dfsg-1 · all · trixie

      Fixed · Fixed: 4.0.1-2

      dsa · phppgadmin · debian · 13

    • 7.14.7+dfsg-1 · all · trixie

      Fixed · Fixed: 4.0.1-2

      dsa · phppgadmin · debian · 13

Observed:

References