CVE catalog

CVE-2005-1349

libconvert-uulib-perl: CVE-2005-1349

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
12.84% · Oct 27, 2026

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibconvert-uulib-perlsid1:1.8+dfsg-3fixed
Debianlibconvert-uulib-perlforky1:1.8+dfsg-3fixed
Debianlibconvert-uulib-perltrixie1:1.8+dfsg-2fixed
Debianlibconvert-uulib-perlbookworm1:1.8+dfsg-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibconvert-uulib-perlsourcesid1.0.5.1not yet assignedNot reportedNot reported
Debianlibconvert-uulib-perlsourceforky1.0.5.1not yet assignedNot reportedNot reported
Debianlibconvert-uulib-perlsourcetrixie1.0.5.1not yet assignedNot reportedNot reported
Debianlibconvert-uulib-perlsourcebookworm1.0.5.1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1:1.8+dfsg-1 · amd64 · bookworm

      Fixed · Fixed: 1.0.5.1

      dsa · libconvert-uulib-perl · debian · bookworm; dsa · libconvert-uulib-perl · debian · 12

    • 1:1.8+dfsg-1 · arm64 · bookworm

      Fixed · Fixed: 1.0.5.1

      dsa · libconvert-uulib-perl · debian · bookworm; dsa · libconvert-uulib-perl · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1:1.8+dfsg-2 · amd64 · trixie

      Fixed · Fixed: 1.0.5.1

      dsa · libconvert-uulib-perl · debian · 13

    • 1:1.8+dfsg-2 · arm64 · trixie

      Fixed · Fixed: 1.0.5.1

      dsa · libconvert-uulib-perl · debian · 13

Observed:

References