CVE catalog

CVE-2005-1857

simpleproxy: CVE-2005-1857

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
4.32% · Oct 25, 2026

Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimpleproxysid3.6-1fixed
Debiansimpleproxyforky3.6-1fixed
Debiansimpleproxybookworm3.5-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansimpleproxysourcesid3.2-4mediumNot reportedNot reported
Debiansimpleproxysourceforky3.2-4mediumNot reportedNot reported
Debiansimpleproxysourcebookworm3.2-4mediumNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [simpleproxy]

    Details (2)
    • 3.5-1+b2 · amd64 · bookworm

      Fixed · Fixed: 3.2-4

      dsa · simpleproxy · debian · bookworm; dsa · simpleproxy · debian · 12

    • 3.5-1+b2 · arm64 · bookworm

      Fixed · Fixed: 3.2-4

      dsa · simpleproxy · debian · bookworm; dsa · simpleproxy · debian · 12

Observed:

References