
CVE catalog
CVE-2005-3656
libapache2-mod-auth-pgsql - format string vulnerability
Multiple format string vulnerabilities in logging functions in mod_auth_pgsql before 2.0.3, when used for user authentication against a PostgreSQL database, allows remote unauthenticated attackers to execute arbitrary code, as demonstrated via the username. security flaw
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 8.90% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian3.1 | libapache2-mod-auth-pgsql | 2.0.2b1-5 | UnknownSource applicability is not established | [DSA-935-1] |
| Debian3.1 | libapache2-mod-auth-pgsql | 2.0.2b1-5sarge0 | UnknownSource applicability is not established | [DSA-935-1] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian3.1 | libapache2-mod-auth-pgsql | 2.0.2b1-5 | UnknownSource applicability is not established | [DSA-935-1] |
| Debian3.1 | libapache2-mod-auth-pgsql | 2.0.2b1-5sarge0 | UnknownSource applicability is not established | [DSA-935-1] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "libapache2-mod-auth-pgsql",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.2b1-5sarge0"
}
]
}
],
"release": "3.1",
"versions": [
"2.0.2b1-5"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DSA-935-1",
"fixed_version": "2.0.2b1-5sarge0",
"provider_source": "pypi",
"provider_record_id": "DSA-935-1",
"provider_updated_at": "2026-03-09T02:10:41.306066Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: