CVE catalog

CVE-2005-3665

phpmyadmin: CVE-2005-3665

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
1.80% · Oct 25, 2026

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.7.0 allow remote attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST variable and (2) various scripts in the libraries directory that handle header generation.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphpmyadminsid4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadminforky4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadmintrixie4:5.2.2-really+dfsg-1+deb13u1fixed
Debianphpmyadminbookworm4:5.2.1+dfsg-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphpmyadminsourcesid4:2.6.4-pl4-2mediumNot reported[340438]
Debianphpmyadminsourceforky4:2.6.4-pl4-2mediumNot reported[340438]
Debianphpmyadminsourcetrixie4:2.6.4-pl4-2mediumNot reported[340438]
Debianphpmyadminsourcebookworm4:2.6.4-pl4-2mediumNot reported[340438]

[Debian bug #340438]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:2.6.4-pl4-2

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:2.6.4-pl4-2

      dsa · phpmyadmin · debian · bookworm; dsa · phpmyadmin · debian · 12

[Debian 13 (Trixie)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:2.6.4-pl4-2

      dsa · phpmyadmin · debian · 13

    • 4:5.2.2-really+dfsg-1+deb13u1 · all · trixie

      Fixed · Fixed: 4:2.6.4-pl4-2

      dsa · phpmyadmin · debian · 13

Observed:

References