CVE catalog

CVE-2005-3862

unalz: CVE-2005-3862

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
20.44% · Oct 25, 2026

Buffer overflow in unalz before 0.53 allows remote attackers to execute arbitrary code via long file names in ALZ archives.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianunalzsid0.65-9fixed
Debianunalzforky0.65-9fixed
Debianunalztrixie0.65-9fixed
Debianunalzbookworm0.65-8fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianunalzsourcesid0.55-1mediumNot reported[340842]
Debianunalzsourceforky0.55-1mediumNot reported[340842]
Debianunalzsourcetrixie0.55-1mediumNot reported[340842]
Debianunalzsourcebookworm0.55-1mediumNot reported[340842]

[Debian bug #340842]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [unalz]Fixed
    Details (2)
    • 0.65-8 · amd64 · bookworm

      Fixed · Fixed: 0.55-1

      dsa · unalz · debian · bookworm; dsa · unalz · debian · 12

    • 0.65-8 · arm64 · bookworm

      Fixed · Fixed: 0.55-1

      dsa · unalz · debian · bookworm; dsa · unalz · debian · 12

[Debian 13 (Trixie)]

  • [unalz]Fixed

    Source package: [unalz]

    Details (2)
    • 0.65-9 · amd64 · trixie

      Fixed · Fixed: 0.55-1

      dsa · unalz · debian · 13

    • 0.65-9+b1 · arm64 · trixie

      Fixed · Fixed: 0.55-1

      dsa · unalz · debian · 13

Observed:

References