
CVE catalog
CVE-2006-1242
kernel-source-2.4.27 - several vulnerabilities
The ip_push_pending_frames function in Linux 2.4.x and 2.6.x before 2.6.16 increments the IP ID field when sending a RST after receiving unsolicited TCP SYN-ACK packets, which allows remote attackers to conduct an Idle Scan (nmap -sI) attack, which bypasses intended protections against such attacks. security flaw
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 3.54% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge1 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge2 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge3 | UnknownSource applicability is not established | [DSA-1097-1] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge1 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge2 | UnknownSource applicability is not established | [DSA-1097-1] |
| Debian3.1 | kernel-source-2.4.27 | 2.4.27-10sarge3 | UnknownSource applicability is not established | [DSA-1097-1] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "kernel-source-2.4.27",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.27-10sarge3"
}
]
}
],
"release": "3.1",
"versions": [
"2.4.27-10",
"2.4.27-10sarge1",
"2.4.27-10sarge2"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DSA-1097-1",
"fixed_version": "2.4.27-10sarge3",
"provider_source": "pypi",
"provider_record_id": "DSA-1097-1",
"provider_updated_at": "2026-03-09T01:01:58.329907Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: