CVE catalog

CVE-2008-0285

ngircd: CVE-2008-0285

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.80% · Oct 25, 2026

ngIRCd 0.10.x before 0.10.4 and 0.11.0 before 0.11.0-pre2 allows remote attackers to cause a denial of service (crash) via crafted IRC PART message, which triggers an invalid dereference.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianngircdsid28-1fixed
Debianngircdforky28-1fixed
Debianngircdtrixie27-2fixed
Debianngircdbookworm26.1-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianngircdsourcesid0.10.3-2lowNot reported[461067]
Debianngircdsourceforky0.10.3-2lowNot reported[461067]
Debianngircdsourcetrixie0.10.3-2lowNot reported[461067]
Debianngircdsourcebookworm0.10.3-2lowNot reported[461067]

[Debian bug #461067]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ngircd]Fixed
    Details (2)
    • 26.1-1+deb12u1 · amd64 · bookworm

      Fixed · Fixed: 0.10.3-2

      dsa · ngircd · debian · bookworm; dsa · ngircd · debian · 12

    • 26.1-1+deb12u1 · arm64 · bookworm

      Fixed · Fixed: 0.10.3-2

      dsa · ngircd · debian · bookworm; dsa · ngircd · debian · 12

[Debian 13 (Trixie)]

  • [ngircd]Fixed

    Source package: [ngircd]

    Details (2)
    • 27-2 · amd64 · trixie

      Fixed · Fixed: 0.10.3-2

      dsa · ngircd · debian · 13

    • 27-2+b1 · arm64 · trixie

      Fixed · Fixed: 0.10.3-2

      dsa · ngircd · debian · 13

Observed:

References