CVE catalog

CVE-2008-0302

apt-listchanges: CVE-2008-0302

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
0.69% · Oct 25, 2026

Untrusted search path vulnerability in apt-listchanges.py in apt-listchanges before 2.82 allows local users to execute arbitrary code via a malicious apt-listchanges program in the current working directory.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianapt-listchangessid4.8.1fixed
Debianapt-listchangesforky4.8.1fixed
Debianapt-listchangestrixie4.8fixed
Debianapt-listchangesbookworm3.24fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianapt-listchangessourcesid2.82mediumNot reportedNot reported
Debianapt-listchangessourceforky2.82mediumNot reportedNot reported
Debianapt-listchangessourcetrixie2.82mediumNot reportedNot reported
Debianapt-listchangessourcebookworm2.82mediumNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 3.24 · all · bookworm

      Fixed · Fixed: 2.82

      dsa · apt-listchanges · debian · bookworm; dsa · apt-listchanges · debian · 12

    • 3.24 · all · bookworm

      Fixed · Fixed: 2.82

      dsa · apt-listchanges · debian · bookworm; dsa · apt-listchanges · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 4.8 · all · trixie

      Fixed · Fixed: 2.82

      dsa · apt-listchanges · debian · 13

    • 4.8 · all · trixie

      Fixed · Fixed: 2.82

      dsa · apt-listchanges · debian · 13

Observed:

References