CVE catalog

CVE-2008-4456

mysql-dfsg-5.0 - several vulnerabilities

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
7.05% · Oct 27, 2026

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67. mysql: mysql command line client XSS flaw The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianmysql-dfsg-5.04.05.0.32-7etch1vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch3vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch3~bpo31+1vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch4vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch5vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch5~bpo31+1vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch6vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch8vulnerable
Debianmysql-dfsg-5.04.05.0.32-7etch10fixed
Debianmysql-dfsg-5.05.05.0.51a-23vulnerable
Debianmysql-dfsg-5.05.05.0.51a-24vulnerable
Debianmysql-dfsg-5.05.05.0.51a-24+lenny1~bpo40+1vulnerable
Debianmysql-dfsg-5.05.05.0.51a-24~bpo40+1vulnerable
Debianmysql-dfsg-5.05.05.0.51a-24+lenny1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianmysql-dfsg-5.0deb4.05.0.32-7etch10Not reportedDSA-1783-1Not reported
Debianmysql-dfsg-5.0deb5.05.0.51a-24+lenny1Not reportedDSA-1783-1Not reported

OpenFactory catalog packages

No matching packages in this catalog.

Observed:

References