CVE catalog

CVE-2008-5587

DEBIAN-CVE-2008-5587

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
12.86% · Oct 25, 2026

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphppgadmin134.2.1-1.1fixed
Debianphppgadmin144.2.1-1.1fixed
OpensusephpPgAdmintumbleweed5.1-5.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphppgadmindeb134.2.1-1.1Not reportedDEBIAN-CVE-2008-5587Not reported
Debianphppgadmindeb144.2.1-1.1Not reportedDEBIAN-CVE-2008-5587Not reported
OpensusephpPgAdminrpmtumbleweed5.1-5.1Not reportedOPENSUSE-SU-2024:10035-1Not reported

OpenFactory catalog packages

[openSUSE Tumbleweed]

  • Source package: [phpPgAdmin]

    Details (1)
    • 7.14.7-1.3 · noarch · tumbleweed

      Unknown · Fixed: 5.1-5.1

      Version impact unknown

      pypi · phpPgAdmin · opensuse · tumbleweed

  • [phpPgAdmin]Fixed

    Source package: [phpPgAdmin]

    Details (1)
    • 7.14.7-1.3 · noarch · tumbleweed

      Fixed · Fixed: 5.1-5.1

      pypi · phpPgAdmin · opensuse · tumbleweed

[Debian 13 (Trixie)]

  • [phppgadmin]Fixed
    Details (2)
    • 7.14.7+dfsg-1 · all · trixie

      Fixed · Fixed: 4.2.1-1.1

      pypi · phppgadmin · debian · 13

    • 7.14.7+dfsg-1 · all · trixie

      Fixed · Fixed: 4.2.1-1.1

      pypi · phppgadmin · debian · 13

Observed:

References