CVE catalog

CVE-2008-6393

psi: CVE-2008-6393

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
18.20% · Oct 27, 2026

PSI Jabber client before 0.12.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a file transfer request with a negative value in a SOCKS5 option, which bypasses a signed integer check and triggers an integer overflow and a heap-based buffer overflow.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpsisid1.5+dfsg1-2.1fixed
Debianpsitrixie1.5+dfsg1-2fixed
Debianpsibookworm1.5+dfsg1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpsisourcesid0.12.1-1lowNot reported[518468]
Debianpsisourcetrixie0.12.1-1lowNot reported[518468]
Debianpsisourcebookworm0.12.1-1lowNot reported[518468]

[Debian bug #518468]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [psi]Fixed

    Source package: [psi]

    Details (2)
    • 1.5+dfsg1-1+b1 · amd64 · bookworm

      Fixed · Fixed: 0.12.1-1

      dsa · psi · debian · bookworm; dsa · psi · debian · 12

    • 1.5+dfsg1-1+b1 · arm64 · bookworm

      Fixed · Fixed: 0.12.1-1

      dsa · psi · debian · bookworm; dsa · psi · debian · 12

[Debian 13 (Trixie)]

  • [psi]Fixed
    Details (2)
    • 1.5+dfsg1-2 · amd64 · trixie

      Fixed · Fixed: 0.12.1-1

      dsa · psi · debian · 13

    • 1.5+dfsg1-2 · arm64 · trixie

      Fixed · Fixed: 0.12.1-1

      dsa · psi · debian · 13

Observed:

References