CVE catalog

CVE-2008-7315

libui-dialog-perl: CVE-2008-7315

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
3.43% · Oct 25, 2026

UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibui-dialog-perlsid1.21-1fixed
Debianlibui-dialog-perlforky1.21-1fixed
Debianlibui-dialog-perltrixie1.21-0.1fixed
Debianlibui-dialog-perlbookworm1.21-0.1fixed
Ubuntulibui-dialog-perl16.041.09-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibui-dialog-perlsourcesid1.21-0.1not yet assignedNot reported[496448]
Debianlibui-dialog-perlsourceforky1.21-0.1not yet assignedNot reported[496448]
Debianlibui-dialog-perlsourcetrixie1.21-0.1not yet assignedNot reported[496448]
Debianlibui-dialog-perlsourcebookworm1.21-0.1not yet assignedNot reported[496448]

[Debian bug #496448]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 1.21-0.1 · all · bookworm

      Fixed · Fixed: 1.21-0.1

      dsa · libui-dialog-perl · debian · bookworm; dsa · libui-dialog-perl · debian · 12

    • 1.21-0.1 · all · bookworm

      Fixed · Fixed: 1.21-0.1

      dsa · libui-dialog-perl · debian · bookworm; dsa · libui-dialog-perl · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 1.21-0.1 · all · trixie

      Fixed · Fixed: 1.21-0.1

      dsa · libui-dialog-perl · debian · 13

    • 1.21-0.1 · all · trixie

      Fixed · Fixed: 1.21-0.1

      dsa · libui-dialog-perl · debian · 13

Observed:

References