CVE catalog

CVE-2009-0195

xpdf: CVE-2009-0195

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
5.37% · Oct 25, 2026

Heap-based buffer overflow in Xpdf 3.02pl2 and earlier, CUPS 1.3.9, and probably other products, allows remote attackers to execute arbitrary code via a PDF file with crafted JBIG2 symbol dictionary segments.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianxpdfsid3.04+git20260802-1fixed
Debianxpdfforky3.04+git20260802-1fixed
Debianxpdftrixie3.04+git20250304-1fixed
Debianxpdfbookworm3.04+git20220601-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianxpdfsourcesid3.02-1.4+lenny1mediumNot reported[524809]
Debianxpdfsourceforky3.02-1.4+lenny1mediumNot reported[524809]
Debianxpdfsourcetrixie3.02-1.4+lenny1mediumNot reported[524809]
Debianxpdfsourcebookworm3.02-1.4+lenny1mediumNot reported[524809]

[Debian bug #524809]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [xpdf]Fixed

    Source package: [xpdf]

    Details (2)
    • 3.04+git20220601-1+b2 · amd64 · bookworm

      Fixed · Fixed: 3.02-1.4+lenny1

      dsa · xpdf · debian · bookworm; dsa · xpdf · debian · 12

    • 3.04+git20220601-1+b2 · arm64 · bookworm

      Fixed · Fixed: 3.02-1.4+lenny1

      dsa · xpdf · debian · bookworm; dsa · xpdf · debian · 12

[Debian 13 (Trixie)]

  • [xpdf]Fixed

    Source package: [xpdf]

    Details (2)
    • 3.04+git20250304-1+b1 · amd64 · trixie

      Fixed · Fixed: 3.02-1.4+lenny1

      dsa · xpdf · debian · 13

    • 3.04+git20250304-1+b1 · arm64 · trixie

      Fixed · Fixed: 3.02-1.4+lenny1

      dsa · xpdf · debian · 13

Observed:

References