
CVE catalog
CVE-2009-0773
xulrunner - several vulnerabilities
The JavaScript engine in Mozilla Firefox before 3.0.7, Thunderbird before 2.0.0.21, and SeaMonkey 1.1.15 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via (1) a splice of an array that contains "some non-set elements," which causes jsarray.cpp to pass an incorrect argument to the ResizeSlots function, which triggers memory corruption; (2) vectors related to js_DecompileValueGenerator, jsopcode.cpp, __defineSetter__, and watch, which triggers an assertion failure or a segmentation fault; and (3) vectors related to gczeal, __defineSetter__, and watch, which triggers a hang.
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 5.79% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian5.0 | xulrunner | 1.9.0.5-1 | UnknownSource applicability is not established | [DSA-1751-1] |
| Debian5.0 | xulrunner | 1.9.0.6-1 | UnknownSource applicability is not established | [DSA-1751-1] |
| Debian5.0 | xulrunner | 1.9.0.7-0lenny1 | UnknownSource applicability is not established | [DSA-1751-1] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian5.0 | xulrunner | 1.9.0.5-1 | UnknownSource applicability is not established | [DSA-1751-1] |
| Debian5.0 | xulrunner | 1.9.0.6-1 | UnknownSource applicability is not established | [DSA-1751-1] |
| Debian5.0 | xulrunner | 1.9.0.7-0lenny1 | UnknownSource applicability is not established | [DSA-1751-1] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "xulrunner",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.0.7-0lenny1"
}
]
}
],
"release": "5.0",
"versions": [
"1.9.0.5-1",
"1.9.0.6-1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DSA-1751-1",
"fixed_version": "1.9.0.7-0lenny1",
"provider_source": "pypi",
"provider_record_id": "DSA-1751-1",
"provider_updated_at": "2026-03-09T01:23:39.156192Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_10218-1.json]
- [https://osv.dev/vulnerability/DSA-1751-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2009/cve-2009-0773.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]