CVE catalog

CVE-2009-2042

libpng - several vulnerabilities

[CVE catalog]

libpng before 1.2.37 does not properly parse 1-bit interlaced images with width values that are not divisible by 8, which causes libpng to include uninitialized bits in certain rows of a PNG file and might allow remote attackers to read portions of sensitive memory via "out-of-bounds pixels" in the file. libpng: Interlaced Images Information Disclosure Vulnerability The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
2.28% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debian5.0libpng1.2.27-2UnknownSource applicability is not established[DSA-2032-1]
Debian5.0libpng1.2.27-2+lenny2UnknownSource applicability is not established[DSA-2032-1]
Debian5.0libpng1.2.27-2+lenny3UnknownSource applicability is not established[DSA-2032-1]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debian5.0libpng1.2.27-2UnknownSource applicability is not established[DSA-2032-1]
Debian5.0libpng1.2.27-2+lenny2UnknownSource applicability is not established[DSA-2032-1]
Debian5.0libpng1.2.27-2+lenny3UnknownSource applicability is not established[DSA-2032-1]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "libpng",
      "distro": "debian",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.2.27-2+lenny3"
            }
          ]
        }
      ],
      "release": "5.0",
      "versions": [
        "1.2.27-2",
        "1.2.27-2+lenny2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/DSA-2032-1",
      "fixed_version": "1.2.27-2+lenny3",
      "provider_source": "pypi",
      "provider_record_id": "DSA-2032-1",
      "provider_updated_at": "2026-03-09T01:19:43.292389Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

Observed:

References