
CVE catalog
CVE-2009-3163
silc-client silc-toolkit - arbitrary code execution
Multiple format string vulnerabilities in lib/silcclient/command.c in Secure Internet Live Conferencing (SILC) Toolkit before 1.1.10, and SILC Client 1.1.8 and earlier, allow remote attackers to execute arbitrary code via format string specifiers in a channel name, related to (1) silc_client_command_topic, (2) silc_client_command_kick, (3) silc_client_command_leave, and (4) silc_client_command_users. Not vulnerable. This issue did not affect the versions of libsilc as shipped with Red Hat Enterprise Linux 4, or 5.
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 4.53% · Oct 27, 2026
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian5.0 | silc-client | 1.1.4-1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-client | 1.1.4-1+lenny1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-client | 1.1.4-1+lenny1~bpo40+1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2+lenny1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2+lenny1~bpo40+1 | UnknownSource applicability is not established | [DSA-1879-1] |
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debian5.0 | silc-client | 1.1.4-1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-client | 1.1.4-1+lenny1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-client | 1.1.4-1+lenny1~bpo40+1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2+lenny1 | UnknownSource applicability is not established | [DSA-1879-1] |
| Debian5.0 | silc-toolkit | 1.1.7-2+lenny1~bpo40+1 | UnknownSource applicability is not established | [DSA-1879-1] |
Original provider fields
{
"package_releases": [],
"fixed_versions": [],
"distribution_packages": [
{
"name": "silc-toolkit",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.7-2+lenny1"
}
]
}
],
"release": "5.0",
"versions": [
"1.1.7-2",
"1.1.7-2+lenny1~bpo40+1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DSA-1879-1",
"fixed_version": "1.1.7-2+lenny1",
"provider_source": "pypi",
"provider_record_id": "DSA-1879-1",
"provider_updated_at": "2026-03-09T01:18:05.991348Z",
"applicability_unknown": true
},
{
"name": "silc-client",
"distro": "debian",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.4-1+lenny1"
}
]
}
],
"release": "5.0",
"versions": [
"1.1.4-1",
"1.1.4-1+lenny1~bpo40+1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/DSA-1879-1",
"fixed_version": "1.1.4-1+lenny1",
"provider_source": "pypi",
"provider_record_id": "DSA-1879-1",
"provider_updated_at": "2026-03-09T01:18:05.991348Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
Observed: