CVE catalog

CVE-2009-4363

horde3 - cross-site scripting

[CVE catalog]

Text_Filter/lib/Horde/Text/Filter/Xss.php in Horde Application Framework before 3.3.6, Horde Groupware before 1.2.5, and Horde Groupware Webmail Edition before 1.2.5 does not properly handle data: URIs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via data:text/html values for the HREF attribute of an A element in an HTML e-mail message. NOTE: the vendor states that the issue is caused by "an XSS vulnerability in Firefox browsers." Red Hat Product Security has determined that this vulnerability does not affect any currently supported Red Hat product. This assessment may evolve based on further analysis and discovery. For more information about this vulnerability and the products it affects, please see the linked references.

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
1.37% · Oct 27, 2026

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debian5.0horde33.2.2+debian0-2+lenny2UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch1UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch2UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch3UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch4UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch5UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch6UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch7UnknownSource applicability is not established[DSA-1966-1]
Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debian4.0horde33.1.3-4UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch1UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch2UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch3UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch4UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch5UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch6UnknownSource applicability is not established[DSA-1966-1]
Debian4.0horde33.1.3-4etch7UnknownSource applicability is not established[DSA-1966-1]
Debian5.0horde33.2.2+debian0-2+lenny2UnknownSource applicability is not established[DSA-1966-1]
Original provider fields
{
  "package_releases": [],
  "fixed_versions": [],
  "distribution_packages": [
    {
      "name": "horde3",
      "distro": "debian",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "3.1.3-4etch7"
            }
          ]
        }
      ],
      "release": "4.0",
      "versions": [
        "3.1.3-4",
        "3.1.3-4etch1",
        "3.1.3-4etch2",
        "3.1.3-4etch3",
        "3.1.3-4etch4",
        "3.1.3-4etch5",
        "3.1.3-4etch6"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/DSA-1966-1",
      "fixed_version": "3.1.3-4etch7",
      "provider_source": "pypi",
      "provider_record_id": "DSA-1966-1",
      "provider_updated_at": "2026-03-09T01:18:20.444443Z",
      "applicability_unknown": true
    },
    {
      "name": "horde3",
      "distro": "debian",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "3.2.2+debian0-2+lenny2"
            }
          ]
        }
      ],
      "release": "5.0",
      "versions": [],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/DSA-1966-1",
      "fixed_version": "3.2.2+debian0-2+lenny2",
      "provider_source": "pypi",
      "provider_record_id": "DSA-1966-1",
      "provider_updated_at": "2026-03-09T01:18:20.444443Z",
      "applicability_unknown": true
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

Observed:

References