CVE catalog

CVE-2010-0793

barnowl: CVE-2010-0793

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
3.81% · Oct 25, 2026

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianbarnowlsid1.10-2fixed
Debianbarnowlforky1.10-2fixed
Debianbarnowltrixie1.10-2fixed
Debianbarnowlbookworm1.10-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianbarnowlsourcesid1.5.1-1not yet assignedNot reported[574418]
Debianbarnowlsourceforky1.5.1-1not yet assignedNot reported[574418]
Debianbarnowlsourcetrixie1.5.1-1not yet assignedNot reported[574418]
Debianbarnowlsourcebookworm1.5.1-1not yet assignedNot reported[574418]

[Debian bug #574418]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [barnowl]Fixed

    Source package: [barnowl]

    Details (2)
    • 1.10-2+b4 · amd64 · bookworm

      Fixed · Fixed: 1.5.1-1

      dsa · barnowl · debian · bookworm; dsa · barnowl · debian · 12

    • 1.10-2+b4 · arm64 · bookworm

      Fixed · Fixed: 1.5.1-1

      dsa · barnowl · debian · bookworm; dsa · barnowl · debian · 12

[Debian 13 (Trixie)]

  • [barnowl]Fixed

    Source package: [barnowl]

    Details (2)
    • 1.10-2+b9 · amd64 · trixie

      Fixed · Fixed: 1.5.1-1

      dsa · barnowl · debian · 13

    • 1.10-2+b9 · arm64 · trixie

      Fixed · Fixed: 1.5.1-1

      dsa · barnowl · debian · 13

Observed:

References