CVE catalog

CVE-2010-1594

ocsinventory-server: CVE-2010-1594

[CVE catalog]

Severity
Low
Published
Source
[NVD] · [CVE record]
EPSS
1.13% · Oct 25, 2026

Multiple cross-site scripting (XSS) vulnerabilities in ocsreports/index.php in OCS Inventory NG 1.02.1 allow remote attackers to inject arbitrary web script or HTML via (1) the query string, (2) the BASE parameter, or (3) the ega_1 parameter. NOTE: some of these details are obtained from third party information.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianocsinventory-serversid2.8.1+dfsg1+~2.11.1-3fixed
Debianocsinventory-serverbookworm2.8.1+dfsg1+~2.11.1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianocsinventory-serversourcesid1.02.1-1unimportantNot reportedNot reported
Debianocsinventory-serversourcebookworm1.02.1-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [ocsinventory-server]

    Details (2)
    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 1.02.1-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 1.02.1-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

  • Details (2)
    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 1.02.1-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

    • 2.8.1+dfsg1+~2.11.1-1 · all · bookworm

      Fixed · Fixed: 1.02.1-1

      dsa · ocsinventory-server · debian · bookworm; dsa · ocsinventory-server · debian · 12

Observed:

References