
CVE catalog
CVE-2010-4469
openjdk-6 - several
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 2.92% · Oct 25, 2026
Unspecified vulnerability in the Java Runtime Environment (JRE) in Oracle Java SE and Java for Business 6 Update 23 and earlier, 5.0 Update 27 and earlier, and 1.4.2_29 and earlier allows remote untrusted Java Web Start applications and untrusted Java applets to affect confidentiality, integrity, and availability via unknown vectors related to HotSpot. NOTE: the previous information was obtained from the February 2011 CPU. Oracle has not commented on claims from a downstream vendor that this issue is heap corruption related to the Verifier and "backward jsrs." OpenJDK Hotspot verifier heap corruption (6878713) The CVSS score(s) listed for this vulnerability do not reflect the associated product's status, and are included for informational purposes to better understand the severity of this vulnerability.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | openjdk-6 | 5.0 | 6b11-9.1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b11-9.1+lenny2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b12-0 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b12-1~exp1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b12~pre1-0 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b12~pre2-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1.5~pre1-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1.5~pre1-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1.5~pre1-3 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1.5~pre1-4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1.5~pre1-5 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b14-1~exp1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-1.6-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-1.6.1-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-1.6.1-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-1.6~pre2-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-3 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b16-4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b17-1.7-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b17-1.7-1+sh4.1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b17~pre3-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b17~pre3-1+sh4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b17~pre3-1+sh4.1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8-3 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8-4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.1-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.1-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.2-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.2-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.2-3 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.2-4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.3-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.3-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.3-2+squeeze1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.3-2~lenny1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.4-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.5-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.7-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre1-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre1-2 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre1-3 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre1-4 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre2-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre3-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18~pre4-1 | vulnerable |
| Debian | openjdk-6 | 5.0 | 6b18-1.8.7-2~lenny1 | fixed |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.3-2 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.3-2+squeeze1 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.4-1 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.5-1 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.7-1 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.7-2~lenny1 | vulnerable |
| Debian | openjdk-6 | 6.0 | 6b18-1.8.7-2~squeeze1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | openjdk-6 | deb | 5.0 | 6b18-1.8.7-2~lenny1 | Not reported | DSA-2224-1 | Not reported |
| Debian | openjdk-6 | deb | 6.0 | 6b18-1.8.7-2~squeeze1 | Not reported | DSA-2224-1 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed: