CVE catalog

CVE-2011-1158

feedparser: CVE-2011-1158

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.35% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via an unexpected URI scheme, as demonstrated by a javascript: URI.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianfeedparsersid6.0.12-1fixed
Debianfeedparserforky6.0.12-1fixed
Debianfeedparsertrixie6.0.11-2fixed
Debianfeedparserbookworm6.0.10-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianfeedparsersourcesid5.0.1-1lowNot reported[617998]
Debianfeedparsersourceforky5.0.1-1lowNot reported[617998]
Debianfeedparsersourcetrixie5.0.1-1lowNot reported[617998]
Debianfeedparsersourcebookworm5.0.1-1lowNot reported[617998]

[Debian bug #617998]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [feedparser]

    Details (2)
    • 6.0.10-1 · all · bookworm

      Fixed · Fixed: 5.0.1-1

      dsa · feedparser · debian · bookworm; dsa · feedparser · debian · 12

    • 6.0.10-1 · all · bookworm

      Fixed · Fixed: 5.0.1-1

      dsa · feedparser · debian · bookworm; dsa · feedparser · debian · 12

[Debian 13 (Trixie)]

  • Source package: [feedparser]

    Details (2)
    • 6.0.11-2 · all · trixie

      Fixed · Fixed: 5.0.1-1

      dsa · feedparser · debian · 13

    • 6.0.11-2 · all · trixie

      Fixed · Fixed: 5.0.1-1

      dsa · feedparser · debian · 13

Observed:

References