CVE catalog

CVE-2011-1522

doctrine: CVE-2011-1522

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.02% · Oct 25, 2026

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiandoctrinesid3.7.5+dfsg-1fixed
Debiandoctrineforky3.7.5+dfsg-1fixed
Debiandoctrinetrixie3.3.3+dfsg-1fixed
Debiandoctrinebookworm2.14.1+dfsg-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiandoctrinesourcesid1.2.4-1not yet assignedNot reported[622674]
Debiandoctrinesourceforky1.2.4-1not yet assignedNot reported[622674]
Debiandoctrinesourcetrixie1.2.4-1not yet assignedNot reported[622674]
Debiandoctrinesourcebookworm1.2.4-1not yet assignedNot reported[622674]

[Debian bug #622674]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [doctrine]

    Details (2)
    • 2.14.1+dfsg-1 · all · bookworm

      Fixed · Fixed: 1.2.4-1

      dsa · doctrine · debian · bookworm; dsa · doctrine · debian · 12

    • 2.14.1+dfsg-1 · all · bookworm

      Fixed · Fixed: 1.2.4-1

      dsa · doctrine · debian · bookworm; dsa · doctrine · debian · 12

[Debian 13 (Trixie)]

  • Source package: [doctrine]

    Details (2)
    • 3.3.3+dfsg-1 · all · trixie

      Fixed · Fixed: 1.2.4-1

      dsa · doctrine · debian · 13

    • 3.3.3+dfsg-1 · all · trixie

      Fixed · Fixed: 1.2.4-1

      dsa · doctrine · debian · 13

Observed:

References