CVE catalog

CVE-2011-1755

jabberd2: CVE-2011-1755

[CVE catalog]

Severity
High
Published
Source
[NVD] · [CVE record]
EPSS
3.66% · Oct 25, 2026

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianjabberd2sid2.7.0-10fixed
Debianjabberd2forky2.7.0-10fixed
Debianjabberd2trixie2.7.0-8fixed
Debianjabberd2bookworm2.7.0-4fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianjabberd2sourcesid2.2.8-2.1mediumNot reportedNot reported
Debianjabberd2sourceforky2.2.8-2.1mediumNot reportedNot reported
Debianjabberd2sourcetrixie2.2.8-2.1mediumNot reportedNot reported
Debianjabberd2sourcebookworm2.2.8-2.1mediumNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [jabberd2]Fixed

    Source package: [jabberd2]

    Details (2)
    • 2.7.0-4+b2 · amd64 · bookworm

      Fixed · Fixed: 2.2.8-2.1

      dsa · jabberd2 · debian · bookworm; dsa · jabberd2 · debian · 12

    • 2.7.0-4+b2 · arm64 · bookworm

      Fixed · Fixed: 2.2.8-2.1

      dsa · jabberd2 · debian · bookworm; dsa · jabberd2 · debian · 12

[Debian 13 (Trixie)]

  • [jabberd2]Fixed
    Details (2)
    • 2.7.0-8 · amd64 · trixie

      Fixed · Fixed: 2.2.8-2.1

      dsa · jabberd2 · debian · 13

    • 2.7.0-8 · arm64 · trixie

      Fixed · Fixed: 2.2.8-2.1

      dsa · jabberd2 · debian · 13

Observed:

References