CVE catalog

CVE-2012-0040

simplesamlphp: CVE-2012-0040

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.32% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL parameter.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansimplesamlphpsid2.5.3.1-1fixed
Debiansimplesamlphpforky2.5.3.1-1fixed
Debiansimplesamlphpbookworm1.19.7-1+deb12u2fixed
Debiansimplesamlphpbookworm-security1.19.7-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansimplesamlphpsourcesid1.8.2-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourceforky1.8.2-1not yet assignedNot reportedNot reported
Debiansimplesamlphpsourcebookworm1.8.2-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (4)
    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.8.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u2 · all · bookworm

      Fixed · Fixed: 1.8.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.8.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

    • 1.19.7-1+deb12u1 · all · bookworm-security

      Fixed · Fixed: 1.8.2-1

      dsa · simplesamlphp · debian · bookworm; dsa · simplesamlphp · debian · 12

Observed:

References