CVE catalog

CVE-2012-0790

smokeping: CVE-2012-0790

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.29% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in smokeping_cgi in Smokeping 2.4.2, 2.6.6, and other versions before 2.6.7 allows remote attackers to inject arbitrary web script or HTML via the displaymode parameter.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiansmokepingsid2.8.2+ds-2fixed
Debiansmokepingforky2.8.2+ds-2fixed
Debiansmokepingtrixie2.8.2+ds-1fixed
Debiansmokepingbookworm2.7.3-4.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiansmokepingsourcesid2.6.8-2not yet assignedNot reported[659899]
Debiansmokepingsourceforky2.6.8-2not yet assignedNot reported[659899]
Debiansmokepingsourcetrixie2.6.8-2not yet assignedNot reported[659899]
Debiansmokepingsourcebookworm2.6.8-2not yet assignedNot reported[659899]

[Debian bug #659899]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [smokeping]Fixed
    Details (2)
    • 2.7.3-4.1 · all · bookworm

      Fixed · Fixed: 2.6.8-2

      dsa · smokeping · debian · bookworm; dsa · smokeping · debian · 12

    • 2.7.3-4.1 · all · bookworm

      Fixed · Fixed: 2.6.8-2

      dsa · smokeping · debian · bookworm; dsa · smokeping · debian · 12

[Debian 13 (Trixie)]

  • [smokeping]Fixed
    Details (2)
    • 2.8.2+ds-1 · all · trixie

      Fixed · Fixed: 2.6.8-2

      dsa · smokeping · debian · 13

    • 2.8.2+ds-1 · all · trixie

      Fixed · Fixed: 2.6.8-2

      dsa · smokeping · debian · 13

Observed:

References