CVE catalog

CVE-2012-1151

libdbd-pg-perl: CVE-2012-1151

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.74% · Oct 27, 2026

Multiple format string vulnerabilities in dbdimp.c in DBD::Pg (aka DBD-Pg or libdbd-pg-perl) module before 2.19.0 for Perl allow remote PostgreSQL database servers to cause a denial of service (process crash) via format string specifiers in (1) a crafted database warning to the pg_warn function or (2) a crafted DBD statement to the dbd_st_prepare function.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibdbd-pg-perlsid3.21.2-1fixed
Debianlibdbd-pg-perlforky3.21.2-1fixed
Debianlibdbd-pg-perltrixie3.18.0-1fixed
Debianlibdbd-pg-perlbookworm3.16.0-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibdbd-pg-perlsourcesid2.19.0-1not yet assignedNot reported[661536]
Debianlibdbd-pg-perlsourceforky2.19.0-1not yet assignedNot reported[661536]
Debianlibdbd-pg-perlsourcetrixie2.19.0-1not yet assignedNot reported[661536]
Debianlibdbd-pg-perlsourcebookworm2.19.0-1not yet assignedNot reported[661536]

[Debian bug #661536]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 3.16.0-2 · amd64 · bookworm

      Fixed · Fixed: 2.19.0-1

      dsa · libdbd-pg-perl · debian · bookworm; dsa · libdbd-pg-perl · debian · 12

    • 3.16.0-2 · arm64 · bookworm

      Fixed · Fixed: 2.19.0-1

      dsa · libdbd-pg-perl · debian · bookworm; dsa · libdbd-pg-perl · debian · 12

[Debian 13 (Trixie)]

  • Source package: [libdbd-pg-perl]

    Details (2)
    • 3.18.0-1+b3 · amd64 · trixie

      Fixed · Fixed: 2.19.0-1

      dsa · libdbd-pg-perl · debian · 13

    • 3.18.0-1+b3 · arm64 · trixie

      Fixed · Fixed: 2.19.0-1

      dsa · libdbd-pg-perl · debian · 13

Observed:

References