CVE catalog

CVE-2012-5667

grep: CVE-2012-5667

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
1.02% · Oct 25, 2026

Multiple integer overflows in GNU Grep before 2.11 might allow context-dependent attackers to execute arbitrary code via vectors involving a long input line that triggers a heap-based buffer overflow.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangrepsid3.12-1fixed
Debiangrepforky3.12-1fixed
Debiangreptrixie3.11-4fixed
Debiangrepbookworm3.8-5fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangrepsourcesid2.11-1lowNot reported[701897]
Debiangrepsourceforky2.11-1lowNot reported[701897]
Debiangrepsourcetrixie2.11-1lowNot reported[701897]
Debiangrepsourcebookworm2.11-1lowNot reported[701897]

[Debian bug #701897]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [grep]Fixed
    Details (2)
    • 3.8-5 · amd64 · bookworm

      Fixed · Fixed: 2.11-1

      dsa · grep · debian · bookworm; dsa · grep · debian · 12

    • 3.8-5 · arm64 · bookworm

      Fixed · Fixed: 2.11-1

      dsa · grep · debian · bookworm; dsa · grep · debian · 12

[Debian 13 (Trixie)]

  • [grep]Fixed

    Source package: [grep]

    Details (2)
    • 3.11-4 · amd64 · trixie

      Fixed · Fixed: 2.11-1

      dsa · grep · debian · 13

    • 3.11-4+b1 · arm64 · trixie

      Fixed · Fixed: 2.11-1

      dsa · grep · debian · 13

Observed:

References