CVE catalog

CVE-2012-6685

ruby-nokogiri: CVE-2012-6685

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.17% · Oct 27, 2026

Nokogiri before 1.5.4 is vulnerable to XXE attacks

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-nokogirisid1.19.4+dfsg-1fixed
Debianruby-nokogiriforky1.19.4+dfsg-1fixed
Debianruby-nokogiritrixie1.18.2+dfsg-1fixed
Debianruby-nokogiribookworm1.13.10+dfsg-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-nokogirisourcesid1.5.4-1lowNot reportedNot reported
Debianruby-nokogirisourceforky1.5.4-1lowNot reportedNot reported
Debianruby-nokogirisourcetrixie1.5.4-1lowNot reportedNot reported
Debianruby-nokogirisourcebookworm1.5.4-1lowNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [ruby-nokogiri]

    Details (2)
    • 1.13.10+dfsg-2+b1 · amd64 · bookworm

      Fixed · Fixed: 1.5.4-1

      dsa · ruby-nokogiri · debian · bookworm; dsa · ruby-nokogiri · debian · 12

    • 1.13.10+dfsg-2+b1 · arm64 · bookworm

      Fixed · Fixed: 1.5.4-1

      dsa · ruby-nokogiri · debian · bookworm; dsa · ruby-nokogiri · debian · 12

[Debian 13 (Trixie)]

  • Source package: [ruby-nokogiri]

    Details (2)
    • 1.18.2+dfsg-1+b1 · amd64 · trixie

      Fixed · Fixed: 1.5.4-1

      dsa · ruby-nokogiri · debian · 13

    • 1.18.2+dfsg-1+b1 · arm64 · trixie

      Fixed · Fixed: 1.5.4-1

      dsa · ruby-nokogiri · debian · 13

Observed:

References