CVE catalog

CVE-2013-1802

ruby-extlib: CVE-2013-1802

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
3.42% · Oct 25, 2026

The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-extlibsid0.9.16-3fixed
Debianruby-extlibforky0.9.16-3fixed
Debianruby-extlibtrixie0.9.16-2fixed
Debianruby-extlibbookworm0.9.16-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-extlibsourcesid0.9.15-3not yet assignedNot reported[697895]
Debianruby-extlibsourceforky0.9.15-3not yet assignedNot reported[697895]
Debianruby-extlibsourcetrixie0.9.15-3not yet assignedNot reported[697895]
Debianruby-extlibsourcebookworm0.9.15-3not yet assignedNot reported[697895]

[Debian bug #697895]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 0.9.16-2 · all · bookworm

      Fixed · Fixed: 0.9.15-3

      dsa · ruby-extlib · debian · bookworm; dsa · ruby-extlib · debian · 12

    • 0.9.16-2 · all · bookworm

      Fixed · Fixed: 0.9.15-3

      dsa · ruby-extlib · debian · bookworm; dsa · ruby-extlib · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 0.9.16-2 · all · trixie

      Fixed · Fixed: 0.9.15-3

      dsa · ruby-extlib · debian · 13

    • 0.9.16-2 · all · trixie

      Fixed · Fixed: 0.9.15-3

      dsa · ruby-extlib · debian · 13

Observed:

References