CVE catalog

CVE-2013-1812

ruby-openid: CVE-2013-1812

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
2.13% · Oct 25, 2026

The ruby-openid gem before 2.2.2 for Ruby allows remote OpenID providers to cause a denial of service (CPU consumption) via (1) a large XRDS document or (2) an XML Entity Expansion (XEE) attack.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-openidsid2.9.2debian-5fixed
Debianruby-openidforky2.9.2debian-5fixed
Debianruby-openidtrixie2.9.2debian-4fixed
Debianruby-openidbookworm2.9.2debian-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-openidsourcesid2.1.8debian-6not yet assignedNot reported[702217]
Debianruby-openidsourceforky2.1.8debian-6not yet assignedNot reported[702217]
Debianruby-openidsourcetrixie2.1.8debian-6not yet assignedNot reported[702217]
Debianruby-openidsourcebookworm2.1.8debian-6not yet assignedNot reported[702217]

[Debian bug #702217]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 2.9.2debian-2 · all · bookworm

      Fixed · Fixed: 2.1.8debian-6

      dsa · ruby-openid · debian · bookworm; dsa · ruby-openid · debian · 12

    • 2.9.2debian-2 · all · bookworm

      Fixed · Fixed: 2.1.8debian-6

      dsa · ruby-openid · debian · bookworm; dsa · ruby-openid · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 2.9.2debian-4 · all · trixie

      Fixed · Fixed: 2.1.8debian-6

      dsa · ruby-openid · debian · 13

    • 2.9.2debian-4 · all · trixie

      Fixed · Fixed: 2.1.8debian-6

      dsa · ruby-openid · debian · 13

Observed:

References