CVE catalog

CVE-2013-2503

privoxy: CVE-2013-2503

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.63% · Oct 25, 2026

Privoxy before 3.0.21 does not properly handle Proxy-Authenticate and Proxy-Authorization headers in the client-server data stream, which makes it easier for remote HTTP servers to spoof the intended proxy service via a 407 (aka Proxy Authentication Required) HTTP status code.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianprivoxysid4.2.0-3fixed
Debianprivoxyforky4.2.0-3fixed
Debianprivoxytrixie4.0.0-2fixed
Debianprivoxybookworm3.0.34-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianprivoxysourcesid3.0.21-1lowNot reported[702896]
Debianprivoxysourceforky3.0.21-1lowNot reported[702896]
Debianprivoxysourcetrixie3.0.21-1lowNot reported[702896]
Debianprivoxysourcebookworm3.0.21-1lowNot reported[702896]

[Debian bug #702896]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [privoxy]Fixed
    Details (2)
    • 3.0.34-1 · amd64 · bookworm

      Fixed · Fixed: 3.0.21-1

      dsa · privoxy · debian · bookworm; dsa · privoxy · debian · 12

    • 3.0.34-1 · arm64 · bookworm

      Fixed · Fixed: 3.0.21-1

      dsa · privoxy · debian · bookworm; dsa · privoxy · debian · 12

[Debian 13 (Trixie)]

  • [privoxy]Fixed
    Details (2)
    • 4.0.0-2 · amd64 · trixie

      Fixed · Fixed: 3.0.21-1

      dsa · privoxy · debian · 13

    • 4.0.0-2 · arm64 · trixie

      Fixed · Fixed: 3.0.21-1

      dsa · privoxy · debian · 13

Observed:

References