CVE catalog

CVE-2013-6459

ruby-will-paginate: CVE-2013-6459

[CVE catalog]

Severity
Medium · CVSS 4.3CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Published
Source
[NVD] · [CVE record]
EPSS
2.21% · Oct 25, 2026

Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-will-paginatesid4.0.1-1fixed
Debianruby-will-paginateforky4.0.1-1fixed
Debianruby-will-paginatetrixie3.3.1-1fixed
Debianruby-will-paginatebookworm3.3.1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-will-paginatesourcesid3.0.5-1lowNot reported[733209]
Debianruby-will-paginatesourceforky3.0.5-1lowNot reported[733209]
Debianruby-will-paginatesourcetrixie3.0.5-1lowNot reported[733209]
Debianruby-will-paginatesourcebookworm3.0.5-1lowNot reported[733209]

[Debian bug #733209]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (2)
    • 3.3.1-1 · all · bookworm

      Fixed · Fixed: 3.0.5-1

      dsa · ruby-will-paginate · debian · bookworm; dsa · ruby-will-paginate · debian · 12

    • 3.3.1-1 · all · bookworm

      Fixed · Fixed: 3.0.5-1

      dsa · ruby-will-paginate · debian · bookworm; dsa · ruby-will-paginate · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 3.3.1-1 · all · trixie

      Fixed · Fixed: 3.0.5-1

      dsa · ruby-will-paginate · debian · 13

    • 3.3.1-1 · all · trixie

      Fixed · Fixed: 3.0.5-1

      dsa · ruby-will-paginate · debian · 13

Observed:

References