CVE catalog

CVE-2014-0061

postgresql-plsh: CVE-2014-0061

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
4.93% · Oct 25, 2026

The validator functions for the procedural languages (PLs) in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to gain privileges via a function that is (1) defined in another language or (2) not allowed to be directly called by the user due to permissions.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpostgresql-plshsid1.20220917-4fixed
Debianpostgresql-plshforky1.20220917-4fixed
Debianpostgresql-plshtrixie1.20220917-3fixed
Debianpostgresql-plshbookworm1.20220917-1fixed
Ubuntupostgresql-9.114.049.1.10-1vulnerable
Ubuntupostgresql-9.114.049.1.10-1bzr1vulnerable
Ubuntupostgresql-9.114.049.1.11-1vulnerable
Ubuntupostgresql-9.114.049.1.11-2vulnerable
Ubuntupostgresql-9.114.049.1.12-1fixed
Ubuntupostgresql-9.314.049.3.1-1vulnerable
Ubuntupostgresql-9.314.049.3.2-1vulnerable
Ubuntupostgresql-9.314.049.3.2-1ubuntu1vulnerable
Ubuntupostgresql-9.314.049.3.2-1ubuntu2vulnerable
Ubuntupostgresql-9.314.049.3.3-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpostgresql-plshsourcesid1.20140221-1not yet assignedNot reportedNot reported
Debianpostgresql-plshsourceforky1.20140221-1not yet assignedNot reportedNot reported
Debianpostgresql-plshsourcetrixie1.20140221-1not yet assignedNot reportedNot reported
Debianpostgresql-plshsourcebookworm1.20140221-1not yet assignedNot reportedNot reported
Ubuntupostgresql-9.1deb14.049.1.12-1Not reportedUBUNTU-CVE-2014-0061Not reported
Ubuntupostgresql-9.3deb14.049.3.3-1Not reportedUBUNTU-CVE-2014-0061Not reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [postgresql-plsh]

    Details (2)
    • 1.20220917-1 · arm64 · bookworm

      Fixed · Fixed: 1.20140221-1

      dsa · postgresql-plsh · debian · bookworm; dsa · postgresql-plsh · debian · 12

    • 1.20220917-1+b1 · amd64 · bookworm

      Fixed · Fixed: 1.20140221-1

      dsa · postgresql-plsh · debian · bookworm; dsa · postgresql-plsh · debian · 12

[Debian 13 (Trixie)]

  • Source package: [postgresql-plsh]

    Details (2)
    • 1.20220917-3 · arm64 · trixie

      Fixed · Fixed: 1.20140221-1

      dsa · postgresql-plsh · debian · 13

    • 1.20220917-3+b1 · amd64 · trixie

      Fixed · Fixed: 1.20140221-1

      dsa · postgresql-plsh · debian · 13

Observed:

References