CVE catalog

CVE-2014-0242

mod-wsgi: CVE-2014-0242

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
Source
[NVD] · [CVE record]
EPSS
8.53% · Oct 25, 2026

mod_wsgi module before 3.4 for Apache, when used in embedded mode, might allow remote attackers to obtain sensitive information via the Content-Type header which is generated from memory that may have been freed and then overwritten by a separate thread.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianmod-wsgisid5.0.2-1fixed
Debianmod-wsgiforky5.0.2-1fixed
Debianmod-wsgitrixie5.0.2-1fixed
Debianmod-wsgibookworm4.9.4-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianmod-wsgisourcesid3.4-3not yet assignedNot reportedNot reported
Debianmod-wsgisourceforky3.4-3not yet assignedNot reportedNot reported
Debianmod-wsgisourcetrixie3.4-3not yet assignedNot reportedNot reported
Debianmod-wsgisourcebookworm3.4-3not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [mod-wsgi]

    Details (2)
    • 4.9.4-1+b2 · amd64 · bookworm

      Fixed · Fixed: 3.4-3

      dsa · mod-wsgi · debian · bookworm; dsa · mod-wsgi · debian · 12

    • 4.9.4-1+b2 · arm64 · bookworm

      Fixed · Fixed: 3.4-3

      dsa · mod-wsgi · debian · bookworm; dsa · mod-wsgi · debian · 12

[Debian 13 (Trixie)]

  • Source package: [mod-wsgi]

    Details (2)
    • 5.0.2-1 · amd64 · trixie

      Fixed · Fixed: 3.4-3

      dsa · mod-wsgi · debian · 13

    • 5.0.2-1 · arm64 · trixie

      Fixed · Fixed: 3.4-3

      dsa · mod-wsgi · debian · 13

Observed:

References